summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-01-10 22:01:36 +0000
committerPeter Volkov <pva@gentoo.org>2008-01-10 22:01:36 +0000
commit05cfc1fd52c26670fc4b6134631f397834e4a70e (patch)
tree936a16a9589a05859db09a2d62fd447f42f2dc7d /www-apps/mantisbt
parentRestrict junit dependency. (diff)
downloadgentoo-2-05cfc1fd52c26670fc4b6134631f397834e4a70e.tar.gz
gentoo-2-05cfc1fd52c26670fc4b6134631f397834e4a70e.tar.bz2
gentoo-2-05cfc1fd52c26670fc4b6134631f397834e4a70e.zip
Version bump. Thank all people, who notified me about this release.
(Portage version: 2.1.3.19)
Diffstat (limited to 'www-apps/mantisbt')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/files/digest-mantisbt-1.1.06
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.0.ebuild59
3 files changed, 71 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index cc6a4b2316f1..2e22abb78e03 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.51 2008/01/06 18:28:56 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.52 2008/01/10 22:01:35 pva Exp $
+
+*mantisbt-1.1.0 (10 Jan 2008)
+
+ 10 Jan 2008; <pva@gentoo.org> +mantisbt-1.1.0.ebuild:
+ Version bump. Thank all people, who notified me about this release.
06 Jan 2008; Tobias Scherbaum <dertobi123@gentoo.org>
mantisbt-1.0.8-r1.ebuild:
diff --git a/www-apps/mantisbt/files/digest-mantisbt-1.1.0 b/www-apps/mantisbt/files/digest-mantisbt-1.1.0
new file mode 100644
index 000000000000..0808c0c8e427
--- /dev/null
+++ b/www-apps/mantisbt/files/digest-mantisbt-1.1.0
@@ -0,0 +1,6 @@
+MD5 0b5e99ae4f33dfb7b99ee989a4b70b78 mantis-1.1.0.tar.gz 2501413
+RMD160 79c91c2084d94d6d26b8f707955d2d5c22508fdf mantis-1.1.0.tar.gz 2501413
+SHA256 b7402ecbb0879d21b6a8e2e64fead64a1fb44e65b6948022c11e75f03f3800d1 mantis-1.1.0.tar.gz 2501413
+MD5 22b9b8a00ff29f3c913371963c416b1c mantisbt-1.1.0-current-svn-fixes.patch.gz 6604
+RMD160 5662ba4e932704f4e32c9e59180331a6fdfb8635 mantisbt-1.1.0-current-svn-fixes.patch.gz 6604
+SHA256 24b6060b040f379137b04d442eab236eb2539009aa02c2fa0428bb54bb52d340 mantisbt-1.1.0-current-svn-fixes.patch.gz 6604
diff --git a/www-apps/mantisbt/mantisbt-1.1.0.ebuild b/www-apps/mantisbt/mantisbt-1.1.0.ebuild
new file mode 100644
index 000000000000..792f1eec28c7
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.0.ebuild,v 1.1 2008/01/10 22:01:35 pva Exp $
+
+inherit eutils webapp depend.php
+
+IUSE="bundled-adodb"
+MY_P=mantis-${PV}
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mirror://gentoo/mantisbt-1.1.0-current-svn-fixes.patch.gz"
+
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ !bundled-adodb? ( dev-php/adodb )
+"
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use pcre
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use bundled-adodb ; then
+ sed -i -e \
+ "s:require_once( 'adodb/adodb.inc.php' );:require_once( \$t_core_dir . 'adodb/adodb.inc.php' );:" \
+ "${S}"/core/database_api.php
+ else
+ rm -r "${S}"/core/adodb/
+ fi
+ epatch "${WORKDIR}"/${P}-current-svn-fixes.patch
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/* packages/mantis-httpd.conf
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.0.0.txt
+ webapp_src_install
+}