summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-01 04:01:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-01 04:01:00 +0000
commit65a93e549a5341bcc1c154ad70ed37d7fcf5e800 (patch)
tree90a50015b2d3be9484b77bdd4fe423216cac2dd0 /www-apps/mythweb
parentfixes compile issues (diff)
downloadgentoo-2-65a93e549a5341bcc1c154ad70ed37d7fcf5e800.tar.gz
gentoo-2-65a93e549a5341bcc1c154ad70ed37d7fcf5e800.tar.bz2
gentoo-2-65a93e549a5341bcc1c154ad70ed37d7fcf5e800.zip
fix issues with forget old & mythweb video search
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/mythweb-0.21_p16809.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index ffe60f20c7f5..d5c4b33db28b 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.59 2008/03/10 15:30:17 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.60 2008/04/01 04:01:00 cardoe Exp $
+
+*mythweb-0.21_p16809 (01 Apr 2008)
+
+ 01 Apr 2008; Doug Goldstein <cardoe@gentoo.org>
+ +mythweb-0.21_p16809.ebuild:
+ fix issues with forget old & mythweb video search
10 Mar 2008; Steve Dibb <beandog@gentoo.org> mythweb-0.21_p16468.ebuild:
Add INSTALL to dodoc for reference, bug 212946
diff --git a/www-apps/mythweb/mythweb-0.21_p16809.ebuild b/www-apps/mythweb/mythweb-0.21_p16809.ebuild
new file mode 100644
index 000000000000..2cf981c71c08
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.21_p16809.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_p16809.ebuild,v 1.1 2008/04/01 04:01:00 cardoe Exp $
+
+ESVN_PROJECT="mythplugins"
+
+inherit mythtv webapp depend.php subversion
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+need_httpd_cgi
+need_php5_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use session mysql pcre posix
+}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}"/mythweb
+ dodoc README INSTALL
+
+ dodir "${MY_HTDOCSDIR}"/data
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/mythweb.conf.{apache,lighttpd}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.21.txt
+
+ webapp_src_install
+}