summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:06:29 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:06:29 +0000
commite4bfe326229c41ed10c454f7ef442ad2bf620956 (patch)
tree42b5c2fee322d7306ce36f71a11e5f618d035ffc /www-apps/phpBB
parentamd64 stable (diff)
downloadgentoo-2-e4bfe326229c41ed10c454f7ef442ad2bf620956.tar.gz
gentoo-2-e4bfe326229c41ed10c454f7ef442ad2bf620956.tar.bz2
gentoo-2-e4bfe326229c41ed10c454f7ef442ad2bf620956.zip
Added phpBB-3.0.0 (#207251).
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'www-apps/phpBB')
-rw-r--r--www-apps/phpBB/ChangeLog10
-rw-r--r--www-apps/phpBB/files/digest-phpBB-3.0.03
-rw-r--r--www-apps/phpBB/files/postinstall-en.txt25
-rw-r--r--www-apps/phpBB/phpBB-3.0.0.ebuild39
4 files changed, 72 insertions, 5 deletions
diff --git a/www-apps/phpBB/ChangeLog b/www-apps/phpBB/ChangeLog
index a60cd3407b6e..c4370c411ee1 100644
--- a/www-apps/phpBB/ChangeLog
+++ b/www-apps/phpBB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/phpBB
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.26 2006/12/24 12:42:13 rl03 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.27 2008/01/25 08:06:29 wrobel Exp $
+
+*phpBB-3.0.0 (25 Jan 2008)
+
+ 25 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> files/postinstall-en.txt,
+ +phpBB-3.0.0.ebuild:
+ Added phpBB-3.0.0 (#207251).
*phpBB-2.0.22 (24 Dec 2006)
diff --git a/www-apps/phpBB/files/digest-phpBB-3.0.0 b/www-apps/phpBB/files/digest-phpBB-3.0.0
new file mode 100644
index 000000000000..5afbf393b8f7
--- /dev/null
+++ b/www-apps/phpBB/files/digest-phpBB-3.0.0
@@ -0,0 +1,3 @@
+MD5 683ef1dc2fe875efa7042bde897ed76e phpBB-3.0.0.tar.bz2 1461327
+RMD160 dd579d4028790d1d75287d76aa5be160ad04f818 phpBB-3.0.0.tar.bz2 1461327
+SHA256 99914ef86249798a41aaeacc1f03fcdc170893bde482ca8951e17a9db81a34d7 phpBB-3.0.0.tar.bz2 1461327
diff --git a/www-apps/phpBB/files/postinstall-en.txt b/www-apps/phpBB/files/postinstall-en.txt
index 9f15e7a444b1..6787a37ca813 100644
--- a/www-apps/phpBB/files/postinstall-en.txt
+++ b/www-apps/phpBB/files/postinstall-en.txt
@@ -1,3 +1,22 @@
-Please use install/install.php to configure a new install of phpBB.
-Use install/update_to_latest.php to upgrade your existing version.
-After that, please delete the contribs/ and install/ directories
+You are almost done!
+
+ 0. Setup a database (e.g. MySQL: see
+ http://www.gentoo.org/doc/en/mysql-howto.xml)
+
+ 1. Login on
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
+
+ and finish the installation.
+
+ 2. Move into the directory where you installed phpBB and remove
+ the "install" folder:
+
+ # cd ${MY_INSTALLDIR}
+ # rm -rf install
+
+ 3. You can now launch your browser and point it to your phpBB site:
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
+
+ Enjoy phpBB!
diff --git a/www-apps/phpBB/phpBB-3.0.0.ebuild b/www-apps/phpBB/phpBB-3.0.0.ebuild
new file mode 100644
index 000000000000..bac46ff29033
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-3.0.0.ebuild,v 1.1 2008/01/25 08:06:29 wrobel Exp $
+
+inherit webapp
+
+DESCRIPTION="phpBB is an open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://www.phpbb.com/files/releases/${P}.tar.bz2
+ mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+RDEPEND="virtual/httpd-php
+ virtual/httpd-cgi"
+
+S=${WORKDIR}/${PN}3
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ${S}/docs/*
+
+ cp -pPR * "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}/docs"
+
+ webapp_serverowned "${MY_HTDOCSDIR}/config.php"
+ webapp_serverowned "${MY_HTDOCSDIR}/cache"
+ webapp_serverowned "${MY_HTDOCSDIR}/files"
+ webapp_serverowned "${MY_HTDOCSDIR}/images/avatars/upload"
+ webapp_serverowned "${MY_HTDOCSDIR}/store"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config.php"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}