summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-02-22 12:21:43 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-02-22 12:21:43 +0000
commite1d83b0e73f049736ef31caaa3d862d84f4722d3 (patch)
tree1b76de01fd8214595b06045cd68cf3034cf4c894 /www-apps/phpsysinfo
parentStable for HPPA (bug #210266). (diff)
downloadgentoo-2-e1d83b0e73f049736ef31caaa3d862d84f4722d3.tar.gz
gentoo-2-e1d83b0e73f049736ef31caaa3d862d84f4722d3.tar.bz2
gentoo-2-e1d83b0e73f049736ef31caaa3d862d84f4722d3.zip
The ebuild needs to check php for xml support. Syntax cleanup.
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'www-apps/phpsysinfo')
-rw-r--r--www-apps/phpsysinfo/ChangeLog7
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild18
2 files changed, 16 insertions, 9 deletions
diff --git a/www-apps/phpsysinfo/ChangeLog b/www-apps/phpsysinfo/ChangeLog
index 13f7eb48158b..3d5057c9ba1d 100644
--- a/www-apps/phpsysinfo/ChangeLog
+++ b/www-apps/phpsysinfo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apps/phpsysinfo
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/ChangeLog,v 1.40 2007/09/04 12:59:52 wrobel Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/ChangeLog,v 1.41 2008/02/22 12:21:43 wrobel Exp $
+
+ 22 Feb 2008; Gunnar Wrobel <wrobel@gentoo.org> phpsysinfo-2.5.4.ebuild:
+ The ebuild needs to check php for xml support. Syntax cleanup.
04 Sep 2007; <wrobel@gentoo.org> -phpsysinfo-2.5.2.ebuild,
-phpsysinfo-2.5.3.ebuild:
diff --git a/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild b/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
index a7f9f790e5af..e0f57ba7154d 100644
--- a/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
+++ b/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild,v 1.6 2007/09/02 15:03:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild,v 1.7 2008/02/22 12:21:43 wrobel Exp $
inherit eutils webapp depend.php
@@ -14,19 +14,23 @@ IUSE=""
S=${WORKDIR}/${PN}
-need_php
+need_php_httpd
pkg_setup() {
webapp_pkg_setup
- require_php_with_use pcre
+ require_php_with_use pcre xml
}
src_install() {
webapp_src_preinst
- dodoc ChangeLog README
- cp -R [:dit:]* ${D}${MY_HTDOCSDIR}
- cp config.php.new ${D}${MY_HTDOCSDIR}/config.php
+ dodoc README
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [:dit:]*
+ cp config.php.new config.php
+ doins config.php
+
webapp_configfile ${MY_HTDOCSDIR}/config.php
webapp_src_install
}