summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-02-13 18:33:07 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-02-13 18:33:07 +0000
commitf44b5e06f55e95d2979ea3da98eca5b4b6793b89 (patch)
treef2074508a3b6b19641edc2df286342a110d55fb0 /www-apps/pyblosxom/pyblosxom-1.3.2.ebuild
parentRDEPEND fix, bug #122057 (diff)
downloadgentoo-2-f44b5e06f55e95d2979ea3da98eca5b4b6793b89.tar.gz
gentoo-2-f44b5e06f55e95d2979ea3da98eca5b4b6793b89.tar.bz2
gentoo-2-f44b5e06f55e95d2979ea3da98eca5b4b6793b89.zip
Added pyblosxom-1.3.2, removed pyblosxom-1.3.1
(Portage version: 2.0.54)
Diffstat (limited to 'www-apps/pyblosxom/pyblosxom-1.3.2.ebuild')
-rw-r--r--www-apps/pyblosxom/pyblosxom-1.3.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/pyblosxom/pyblosxom-1.3.2.ebuild b/www-apps/pyblosxom/pyblosxom-1.3.2.ebuild
new file mode 100644
index 000000000000..26794be1a815
--- /dev/null
+++ b/www-apps/pyblosxom/pyblosxom-1.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/pyblosxom/pyblosxom-1.3.2.ebuild,v 1.1 2006/02/13 18:33:07 wrobel Exp $
+
+inherit eutils distutils webapp
+
+DESCRIPTION="PyBlosxom is a lightweight weblog system."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pyblosxom.sourceforge.net/"
+
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/python"
+
+src_unpack() {
+
+ unpack ${A} && cd "${S}"
+
+ epatch ${FILESDIR}/${P}-gentoo.patch || die "Patching failed!"
+
+}
+
+src_install() {
+ webapp_src_preinst
+
+ distutils_src_install
+ dodoc README
+
+ keepdir /usr/share/${P}/plugins
+ keepdir ${MY_HTDOCSDIR}/data
+ keepdir ${MY_HTDOCSDIR}/log
+
+ mkdir -p ${D}${MY_CGIBINDIR}/pyblosxom
+ cp web/{config.py,pyblosxom.cgi} ${D}${MY_CGIBINDIR}/pyblosxom/
+
+ webapp_configfile ${MY_CGIBINDIR}/pyblosxom/config.py
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postupgrade_txt en ${FILESDIR}/postupgrade-en.txt
+ webapp_hook_script ${FILESDIR}/config-hook.sh
+
+ webapp_src_install
+}