summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-05-01 15:33:20 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-05-01 15:33:20 +0000
commitaf35179edaecdc10262d15d5e0b62cb2e3b1182b (patch)
tree2a1d64ff9b0a410f5cb6764f0b38515f17f5b3b6 /www-apps/swish-e
parentadding pdf support flag to local for swish-e (diff)
downloadgentoo-2-af35179edaecdc10262d15d5e0b62cb2e3b1182b.tar.gz
gentoo-2-af35179edaecdc10262d15d5e0b62cb2e3b1182b.tar.bz2
gentoo-2-af35179edaecdc10262d15d5e0b62cb2e3b1182b.zip
New version of swish-e; bug 37165 can be closed
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'www-apps/swish-e')
-rw-r--r--www-apps/swish-e/ChangeLog12
-rw-r--r--www-apps/swish-e/Manifest3
-rw-r--r--www-apps/swish-e/files/digest-swish-e-2.4.31
-rw-r--r--www-apps/swish-e/metadata.xml10
-rw-r--r--www-apps/swish-e/swish-e-2.4.3.ebuild67
5 files changed, 91 insertions, 2 deletions
diff --git a/www-apps/swish-e/ChangeLog b/www-apps/swish-e/ChangeLog
index d5442610dd7d..d5c63fbedd06 100644
--- a/www-apps/swish-e/ChangeLog
+++ b/www-apps/swish-e/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/swish-e
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/ChangeLog,v 1.6 2004/12/29 01:51:25 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/ChangeLog,v 1.7 2005/05/01 15:33:20 mcummings Exp $
+
+*swish-e-2.4.3 (01 May 2005)
+
+ 01 May 2005; Michael Cummings <mcummings@gentoo.org>
+ +swish-e-2.4.3.ebuild:
+ New version of swish-e, which means bug 37165 can finally be closed.
+ Revamped the ebuild a ton - a lot of optional perl modules now, as well as a
+ few I have no good use flag for enabling. Test and let me know :)
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/www-apps/swish-e/Manifest b/www-apps/swish-e/Manifest
index 22b3fa35db2b..1a26dc7c728b 100644
--- a/www-apps/swish-e/Manifest
+++ b/www-apps/swish-e/Manifest
@@ -1,3 +1,6 @@
MD5 11c774f13e831b09173b4108ebef4e54 ChangeLog 1216
MD5 fd29a2ea594430a7274c8d61f1182bb1 swish-e-2.2.2-r1.ebuild 898
+MD5 f78655aeb30ae9c42240c17cc7f28ba0 swish-e-2.4.3.ebuild 1664
MD5 fc5a8d65b3761bfbd7f7744fda4c324e files/digest-swish-e-2.2.2-r1 65
+MD5 0af7d0e3bdf537f307d8f2e7df0bd924 files/digest-swish-e-2.4.3 66
+MD5 face08b2f796d92a6dfa6c1f3bfd2335 files/swish-e-2.4.3-Makefile.PL.patch 417
diff --git a/www-apps/swish-e/files/digest-swish-e-2.4.3 b/www-apps/swish-e/files/digest-swish-e-2.4.3
new file mode 100644
index 000000000000..38c1a2a1c95c
--- /dev/null
+++ b/www-apps/swish-e/files/digest-swish-e-2.4.3
@@ -0,0 +1 @@
+MD5 d611ba8d40fe5340097ca6e8a042ca44 swish-e-2.4.3.tar.gz 1563031
diff --git a/www-apps/swish-e/metadata.xml b/www-apps/swish-e/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/www-apps/swish-e/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/www-apps/swish-e/swish-e-2.4.3.ebuild b/www-apps/swish-e/swish-e-2.4.3.ebuild
new file mode 100644
index 000000000000..e5e70aae7e39
--- /dev/null
+++ b/www-apps/swish-e/swish-e-2.4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/swish-e-2.4.3.ebuild,v 1.1 2005/05/01 15:33:20 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Simple Web Indexing System for Humans - Enhanced"
+HOMEPAGE="http://www.swish-e.org/"
+SRC_URI="http://www.swish-e.org/distribution/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="perl pdf mp3"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ dev-libs/libxml2
+ pdf? ( app-text/xpdf )
+ perl? ( dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Tagset
+ dev-perl/MIME-Types
+ dev-perl/HTML-Template
+ dev-perl/HTML-FillInForm
+ dev-perl/Template-Toolkit
+ mp3? ( dev-perl/MP3-Tag )
+ )"
+
+
+src_unpack() {
+ if has_version 'www-apps/swish-e'; then
+ ewarn "Your old swish-e indexes may not be compatible with this"
+ ewarn "version."
+ epause 10
+ fi
+ unpack ${A}
+ cd ${S}
+}
+src_compile() {
+ cd ${S}
+ econf || die "configuration failed"
+ make || die "emake failed"
+}
+
+src_install() {
+ dobin src/swish-e || die
+ dodoc INSTALL README
+ make DESTDIR="${D}" install
+ if use perl ; then
+ cd ${S}/perl
+ myconf="SWISHBINDIR=${D}/usr/bin SWISHIGNOREVER SWISHSKIPTEST "
+ perl-module_src_compile
+ cd ${S}/perl
+ perl-module_src_install
+ fi
+}
+
+pkg_postinst() {
+
+ einfo "If you wish to be able to index MS Word documents, "
+ einfo "emerge app-text/catdoc"
+ einfo
+ einfo "If you wish to be able to index MS Excel Spreadsheets,"
+ einfo "emerge dev-perl/SpreadSheet-ParseExcel and"
+ einfo "dev-perl/HTML-Parser"
+
+}