summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-09-24 09:07:05 +0000
committerThomas Kahle <tomka@gentoo.org>2013-09-24 09:07:05 +0000
commit3cbc20dbd241b52b76b38f7cfe64a853c68959c3 (patch)
tree5c422bc6e543f5cbffbfa2c8e435c00d37c9a50e /www-apps/tt-rss
parentmono version bump (diff)
downloadgentoo-2-3cbc20dbd241b52b76b38f7cfe64a853c68959c3.tar.gz
gentoo-2-3cbc20dbd241b52b76b38f7cfe64a853c68959c3.tar.bz2
gentoo-2-3cbc20dbd241b52b76b38f7cfe64a853c68959c3.zip
bump and fix bug 484900 (don't assume apache)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'www-apps/tt-rss')
-rw-r--r--www-apps/tt-rss/ChangeLog8
-rw-r--r--www-apps/tt-rss/files/ttrssd.initd-r24
-rw-r--r--www-apps/tt-rss/tt-rss-1.10.ebuild79
3 files changed, 88 insertions, 3 deletions
diff --git a/www-apps/tt-rss/ChangeLog b/www-apps/tt-rss/ChangeLog
index 04cd22dd8c64..c2a58f3a6927 100644
--- a/www-apps/tt-rss/ChangeLog
+++ b/www-apps/tt-rss/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/tt-rss
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/ChangeLog,v 1.29 2013/09/12 09:06:28 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/ChangeLog,v 1.30 2013/09/24 09:07:05 tomka Exp $
+
+*tt-rss-1.10 (24 Sep 2013)
+
+ 24 Sep 2013; Thomas Kahle <tomka@gentoo.org> +tt-rss-1.10.ebuild,
+ files/ttrssd.initd-r2, tt-rss-1.9.ebuild:
+ bump and fix bug 484900 (don't assume apache)
12 Sep 2013; Thomas Kahle <tomka@gentoo.org> metadata.xml:
Take maintainership after discussing with previous proxy Patrick.
diff --git a/www-apps/tt-rss/files/ttrssd.initd-r2 b/www-apps/tt-rss/files/ttrssd.initd-r2
index 6464b2987261..3ebadb45b4c8 100644
--- a/www-apps/tt-rss/files/ttrssd.initd-r2
+++ b/www-apps/tt-rss/files/ttrssd.initd-r2
@@ -40,10 +40,10 @@ checkconfig() {
return 1
fi
- # FIXME: This should be done by webapp-config during install
+ # NOTE: This can't be done by webapp-config if we want runtime configurable TTRSSD_GROUP
for dir in ${INSTANCE_FOLDERS}; do
if [ -d "${instance}/${dir}" ]; then
- chown -R "apache:${TTRSSD_GROUP}" "${instance}/${dir}" || return 1
+ chown -R ":${TTRSSD_GROUP}" "${instance}/${dir}" || return 1
chmod -R g+w "${instance}/${dir}" || return 1
fi
done
diff --git a/www-apps/tt-rss/tt-rss-1.10.ebuild b/www-apps/tt-rss/tt-rss-1.10.ebuild
new file mode 100644
index 000000000000..2b7f15375e56
--- /dev/null
+++ b/www-apps/tt-rss/tt-rss-1.10.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/tt-rss-1.10.ebuild,v 1.1 2013/09/24 09:07:05 tomka Exp $
+
+EAPI=5
+
+inherit user eutils webapp depend.php depend.apache vcs-snapshot
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="http://tt-rss.org/"
+SRC_URI="https://github.com/gothfox/Tiny-Tiny-RSS/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="daemon +mysql postgres"
+
+DEPEND="
+ daemon? ( dev-lang/php[mysql?,postgres?,pcntl,curl] )
+ !daemon? ( dev-lang/php[mysql?,postgres?,curl] )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use daemon; then
+ enewgroup ttrssd
+ enewuser ttrssd -1 /bin/sh /dev/null ttrssd
+ fi
+}
+
+src_prepare() {
+ # Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
+ einfo "Customizing config.php..."
+ mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
+
+ if use mysql && ! use postgres; then
+ sed -i \
+ -e "/define('DB_TYPE',/{s:pgsql:mysql:}" \
+ config.php || die
+ fi
+
+ sed -i \
+ -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" \
+ config.php || die
+
+ # per 462578
+ epatch_user
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "/${MY_HTDOCSDIR}"
+ doins -r *
+ keepdir "/${MY_HTDOCSDIR}"/feed-icons
+
+ for DIR in cache lock feed-icons; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ if use daemon; then
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon.txt
+ newinitd "${FILESDIR}"/ttrssd.initd-r2 ttrssd
+ newconfd "${FILESDIR}"/ttrssd.confd-r1 ttrssd
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/ttrssd.logrotated ttrssd
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ fi
+
+ webapp_src_install
+}