summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-11-30 17:55:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-11-30 17:55:05 +0000
commit59d0fbaebc52946e9992c3e38e3afe27f4228eea (patch)
treedf8245b9172e77bece0ed83c5d88d763287f6d10 /www-apps
parentCorrect the parents correctly. (diff)
downloadgentoo-2-59d0fbaebc52946e9992c3e38e3afe27f4228eea.tar.gz
gentoo-2-59d0fbaebc52946e9992c3e38e3afe27f4228eea.tar.bz2
gentoo-2-59d0fbaebc52946e9992c3e38e3afe27f4228eea.zip
Version bump to 3.0.4
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/liquid_feedback_core/ChangeLog9
-rw-r--r--www-apps/liquid_feedback_core/files/liquid_feedback_core-3.0.4-gentoo.patch30
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild43
3 files changed, 81 insertions, 1 deletions
diff --git a/www-apps/liquid_feedback_core/ChangeLog b/www-apps/liquid_feedback_core/ChangeLog
index 6d8b78fc8b10..d85f3205c470 100644
--- a/www-apps/liquid_feedback_core/ChangeLog
+++ b/www-apps/liquid_feedback_core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/liquid_feedback_core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/ChangeLog,v 1.3 2014/11/28 07:55:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/ChangeLog,v 1.4 2014/11/30 17:55:05 tupone Exp $
+
+*liquid_feedback_core-3.0.4 (30 Nov 2014)
+
+ 30 Nov 2014; Alfredo Tupone <tupone@gentoo.org>
+ +liquid_feedback_core-3.0.4.ebuild,
+ +files/liquid_feedback_core-3.0.4-gentoo.patch:
+ Version bump to 3.0.4
*liquid_feedback_core-2.2.6 (28 Nov 2014)
diff --git a/www-apps/liquid_feedback_core/files/liquid_feedback_core-3.0.4-gentoo.patch b/www-apps/liquid_feedback_core/files/liquid_feedback_core-3.0.4-gentoo.patch
new file mode 100644
index 000000000000..fbc91eff2467
--- /dev/null
+++ b/www-apps/liquid_feedback_core/files/liquid_feedback_core-3.0.4-gentoo.patch
@@ -0,0 +1,30 @@
+--- Makefile.old 2014-11-29 22:38:43.200509267 +0100
++++ Makefile 2014-11-29 22:39:16.392199651 +0100
+@@ -1,22 +1,10 @@
+ all:: lf_update lf_update_issue_order lf_update_suggestion_order
+
+-lf_update: lf_update.c
+- cc -Wall -O2 \
+- -I "`pg_config --includedir`" \
+- -L "`pg_config --libdir`" \
+- -o lf_update lf_update.c -lpq
+-
+-lf_update_issue_order: lf_update_issue_order.c
+- cc -Wall -O2 \
+- -I "`pg_config --includedir`" \
+- -L "`pg_config --libdir`" \
+- -o lf_update_issue_order lf_update_issue_order.c -lpq
+-
+-lf_update_suggestion_order: lf_update_suggestion_order.c
+- cc -Wall -O2 \
+- -I "`pg_config --includedir`" \
+- -L "`pg_config --libdir`" \
+- -o lf_update_suggestion_order lf_update_suggestion_order.c -lpq
++CPPFLAGS=-I `pg_config --includedir`
++LDFLAGS=-L `pg_config --libdir`
++CFLAGS=-Wall -O2
++CC=cc
++LDLIBS=-lpq
+
+ clean::
+ rm -f lf_update lf_update_issue_order lf_update_suggestion_order
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
new file mode 100644
index 000000000000..82433abbab5e
--- /dev/null
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild,v 1.1 2014/11/30 17:55:05 tupone Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="virtual/postgresql"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I $(pg_config --includedir)" \
+ LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)" \
+ LDLIBS="-lpq $(pg_config --libs)"
+}
+
+src_install() {
+ dobin lf_update lf_update_suggestion_order lf_export
+ insinto /usr/share/${PN}
+ doins -r {core,init,demo,test}.sql update
+ dodoc README "${FILESDIR}"/postinstall-en.txt
+}