summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:07:22 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:07:22 +0000
commita43cca33dc657b170664baa7c492a950db4757ef (patch)
tree441fa9c2af4c4388972d121ab1e2f186a45c832b /www-client/leechcraft-poshuku
parentBump LeechCraft to 0.5.85, thanks to 0xd34df00d (diff)
downloadgentoo-2-a43cca33dc657b170664baa7c492a950db4757ef.tar.gz
gentoo-2-a43cca33dc657b170664baa7c492a950db4757ef.tar.bz2
gentoo-2-a43cca33dc657b170664baa7c492a950db4757ef.zip
Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'www-client/leechcraft-poshuku')
-rw-r--r--www-client/leechcraft-poshuku/ChangeLog8
-rw-r--r--www-client/leechcraft-poshuku/leechcraft-poshuku-0.5.85.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/www-client/leechcraft-poshuku/ChangeLog b/www-client/leechcraft-poshuku/ChangeLog
index a247049f08a3..baa445c0d648 100644
--- a/www-client/leechcraft-poshuku/ChangeLog
+++ b/www-client/leechcraft-poshuku/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/leechcraft-poshuku
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/leechcraft-poshuku/ChangeLog,v 1.18 2012/09/23 10:10:07 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/leechcraft-poshuku/ChangeLog,v 1.19 2012/10/08 16:07:22 pinkbyte Exp $
+
+*leechcraft-poshuku-0.5.85 (08 Oct 2012)
+
+ 08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-poshuku-0.5.85.ebuild:
+ Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
23 Sep 2012; Sergey Popov <pinkbyte@gentoo.org>
leechcraft-poshuku-9999.ebuild, metadata.xml:
diff --git a/www-client/leechcraft-poshuku/leechcraft-poshuku-0.5.85.ebuild b/www-client/leechcraft-poshuku/leechcraft-poshuku-0.5.85.ebuild
new file mode 100644
index 000000000000..dfc590e8a082
--- /dev/null
+++ b/www-client/leechcraft-poshuku/leechcraft-poshuku-0.5.85.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/leechcraft-poshuku/leechcraft-poshuku-0.5.85.ebuild,v 1.1 2012/10/08 16:07:22 pinkbyte Exp $
+
+EAPI="4"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Poshuku, the full-featured web browser plugin for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +cleanweb +fatape +filescheme +fua +idn +keywords +onlinebookmarks
+ +pcre postgres pogooglue +sqlite wyfv"
+
+DEPEND="~net-misc/leechcraft-core-${PV}[postgres?,sqlite?]
+ x11-libs/qt-webkit:4
+ idn? ( net-dns/libidn )
+ onlinebookmarks? ( >=dev-libs/qjson-0.7.1-r1 )
+ pcre? ( >=dev-libs/libpcre-8.12 )
+"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="pcre? ( cleanweb )"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable cleanweb POSHUKU_CLEANWEB)
+ $(cmake-utils_use_enable fatape POSHUKU_FATAPE)
+ $(cmake-utils_use_enable filescheme POSHUKU_FILESCHEME)
+ $(cmake-utils_use_enable fua POSHUKU_FUA)
+ $(cmake-utils_use_enable idn IDN)
+ $(cmake-utils_use_enable keywords POSHUKU_KEYWORDS)
+ $(cmake-utils_use_enable onlinebookmarks POSHUKU_ONLINEBOOKMARKS)
+ $(cmake-utils_use_enable pcre POSHUKU_CLEANWEB_PCRE)
+ $(cmake-utils_use_enable pogooglue POSHUKU_POGOOGLUE)
+ $(cmake-utils_use_enable wyfv POSHUKU_WYFV)
+ "
+
+ cmake-utils_src_configure
+}