summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-29 19:41:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-29 19:41:51 +0000
commit35cbed89101df1da6078c7b186672edf5cf548b5 (patch)
tree4cf2ddce6bce1b446860f2d7e174f12a6e2f28b7 /www-client/ochusha
parentStable on ia64, bug 150229. (diff)
downloadgentoo-2-35cbed89101df1da6078c7b186672edf5cf548b5.tar.gz
gentoo-2-35cbed89101df1da6078c7b186672edf5cf548b5.tar.bz2
gentoo-2-35cbed89101df1da6078c7b186672edf5cf548b5.zip
Move .desktop file in the correct directory so that it appears on menus, and install icons in the right place. Add ~x86-fbsd keyword.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'www-client/ochusha')
-rw-r--r--www-client/ochusha/ChangeLog9
-rw-r--r--www-client/ochusha/files/digest-ochusha-0.5.8.2-r23
-rw-r--r--www-client/ochusha/ochusha-0.5.8.2-r2.ebuild62
3 files changed, 73 insertions, 1 deletions
diff --git a/www-client/ochusha/ChangeLog b/www-client/ochusha/ChangeLog
index f1262793cafd..6dcf0a93420b 100644
--- a/www-client/ochusha/ChangeLog
+++ b/www-client/ochusha/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/ochusha
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/ochusha/ChangeLog,v 1.20 2006/10/29 16:26:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/ochusha/ChangeLog,v 1.21 2006/10/29 19:41:51 flameeyes Exp $
+
+*ochusha-0.5.8.2-r2 (29 Oct 2006)
+
+ 29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +ochusha-0.5.8.2-r2.ebuild:
+ Move .desktop file in the correct directory so that it appears on menus, and
+ install icons in the right place. Add ~x86-fbsd keyword.
29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
-ochusha-0.5.8.2.ebuild:
diff --git a/www-client/ochusha/files/digest-ochusha-0.5.8.2-r2 b/www-client/ochusha/files/digest-ochusha-0.5.8.2-r2
new file mode 100644
index 000000000000..ee45ff098e36
--- /dev/null
+++ b/www-client/ochusha/files/digest-ochusha-0.5.8.2-r2
@@ -0,0 +1,3 @@
+MD5 167edce1d41f766d18018175458373c7 ochusha-0.5.8.2.tar.bz2 1794268
+RMD160 5990fd327165b3d3c415aec5639babe1ce9ad6ba ochusha-0.5.8.2.tar.bz2 1794268
+SHA256 91a4429b085be335ad34c9af3ed2ab8871b6245839348abe21073a48789dbe7c ochusha-0.5.8.2.tar.bz2 1794268
diff --git a/www-client/ochusha/ochusha-0.5.8.2-r2.ebuild b/www-client/ochusha/ochusha-0.5.8.2-r2.ebuild
new file mode 100644
index 000000000000..52063cb12656
--- /dev/null
+++ b/www-client/ochusha/ochusha-0.5.8.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/ochusha/ochusha-0.5.8.2-r2.ebuild,v 1.1 2006/10/29 19:41:51 flameeyes Exp $
+
+inherit flag-o-matic eutils
+
+IUSE="nls ssl"
+
+DESCRIPTION="Ochusha - 2ch viewer for GTK+"
+HOMEPAGE="http://ochusha.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/16560/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+RDEPEND="virtual/xft
+ >=x11-libs/gtk+-2.2.4
+ >=dev-libs/glib-2.2.3
+ >=dev-libs/libxml2-2.5.0
+ >=gnome-base/libghttp-1.0.9
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-glib-2.10.diff
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ $(use_with ssl) \
+ --enable-regex \
+ --disable-shared \
+ --enable-static \
+ --with-included-oniguruma || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ rm "${D}"/usr/share/ochusha/ochusha.desktop
+
+ insinto /usr/share/applications
+ doins "${S}/gtk2/ochusha.desktop"
+ sed -i -e 's:Icon=.*:Icon=ochusha:' "${D}"/usr/share/applications/ochusha.desktop
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins "${S}/gtk2/ochusha48.png" ochusha.png
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins "${S}/gtk2/ochusha32.png" ochusha.png
+
+ dodoc ACKNOWLEDGEMENT AUTHORS BUGS \
+ ChangeLog INSTALL* NEWS README TODO
+}