summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-21 15:23:33 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-21 15:23:33 +0000
commit53563c537f659e5d44924daf921f0956ab6fe43d (patch)
tree180f4008874a50efef2e89985343e98f739e948a /www-client/rekonq
parentSupport fcron as well as vixie-cron and dcron (with a separate crontab); cron... (diff)
downloadgentoo-2-53563c537f659e5d44924daf921f0956ab6fe43d.tar.gz
gentoo-2-53563c537f659e5d44924daf921f0956ab6fe43d.tar.bz2
gentoo-2-53563c537f659e5d44924daf921f0956ab6fe43d.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'www-client/rekonq')
-rw-r--r--www-client/rekonq/ChangeLog8
-rw-r--r--www-client/rekonq/rekonq-1.0.ebuild43
2 files changed, 49 insertions, 2 deletions
diff --git a/www-client/rekonq/ChangeLog b/www-client/rekonq/ChangeLog
index 87234f5c8eca..f70935c7d4cd 100644
--- a/www-client/rekonq/ChangeLog
+++ b/www-client/rekonq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/rekonq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.45 2012/05/24 11:01:40 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.46 2012/07/21 15:23:33 johu Exp $
+
+*rekonq-1.0 (21 Jul 2012)
+
+ 21 Jul 2012; Johannes Huber <johu@gentoo.org> +rekonq-1.0.ebuild:
+ Version bump.
24 May 2012; Johannes Huber <johu@gentoo.org> -rekonq-0.8.1.ebuild,
-rekonq-0.9.1.ebuild:
@@ -198,4 +203,3 @@
01 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> +rekonq-0.2.90.ebuild:
Initial commit wrt #275686, thanks to Tobias Leupold for reporting.
-
diff --git a/www-client/rekonq/rekonq-1.0.ebuild b/www-client/rekonq/rekonq-1.0.ebuild
new file mode 100644
index 000000000000..a0f228dcf76a
--- /dev/null
+++ b/www-client/rekonq/rekonq-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/rekonq-1.0.ebuild,v 1.1 2012/07/21 15:23:33 johu Exp $
+
+EAPI=4
+
+WEBKIT_REQUIRED="always"
+QT_MINIMAL="4.8"
+KDE_MINIMAL="4.7"
+KDE_SCM="git"
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
+hu is it ja km ko lt nb nds nl pl pt pt_BR ro ru sk sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv th tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A browser based on qt-webkit"
+HOMEPAGE="http://rekonq.kde.org/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/qoauth
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
+"
+RDEPEND="${DEPEND}"
+
+# Almost all test fails
+RESTRICT="test"
+
+src_prepare() {
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ kde4-base_src_prepare
+}