summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-04 14:51:31 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-04 14:51:31 +0000
commit3672de269f537becca7650720ad1498435e7ad08 (patch)
tree5d3033e73200f336ec4df2a7fd2be3d4d50e7561 /www-client
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3672de269f537becca7650720ad1498435e7ad08.tar.gz
gentoo-2-3672de269f537becca7650720ad1498435e7ad08.tar.bz2
gentoo-2-3672de269f537becca7650720ad1498435e7ad08.zip
Copy 2.0.3 bump from overlay. USE-flags have changed names, and USE=system-sqlite has been added
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey/ChangeLog9
-rw-r--r--www-client/seamonkey/metadata.xml21
-rw-r--r--www-client/seamonkey/seamonkey-2.0.3.ebuild277
3 files changed, 301 insertions, 6 deletions
diff --git a/www-client/seamonkey/ChangeLog b/www-client/seamonkey/ChangeLog
index 0c9c5c6f1907..444c32b06464 100644
--- a/www-client/seamonkey/ChangeLog
+++ b/www-client/seamonkey/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/seamonkey
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.211 2010/02/18 00:09:51 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.212 2010/03/04 14:51:31 nirbheek Exp $
+
+*seamonkey-2.0.3 (04 Mar 2010)
+
+ 04 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +seamonkey-2.0.3.ebuild, metadata.xml:
+ Copy 2.0.3 bump from overlay. USE-flags have changed names, and
+ USE=system-sqlite has been added
18 Feb 2010; <anarchy@gentoo.org> +files/seamonkey-rebuild-databases.pl:
Readd seamonkey-rebuild-databases.pl bug #302694
diff --git a/www-client/seamonkey/metadata.xml b/www-client/seamonkey/metadata.xml
index 0f6217ceff83..5ecea480459f 100644
--- a/www-client/seamonkey/metadata.xml
+++ b/www-client/seamonkey/metadata.xml
@@ -3,18 +3,29 @@
<pkgmetadata>
<herd>mozilla</herd>
<use>
+ <!-- New EAPI-1 style USE-flags -->
+ <flag name='chatzilla'>Build Mozilla's IRC client (default on)</flag>
+ <flag name='composer'>Build Mozilla's HTML editor component (default on)</flag>
+ <flag name='mailclient'>Build Mozilla's Mail client (default on)</flag>
+ <flag name='roaming'>Build sroaming extension support (default on)</flag>
+
+ <!-- Old EAPI-0 USE-flags -->
<flag name='mozdevelop'>Enable features for web developers (e.g.
Venkman)</flag>
- <flag name='moznocompose'>Disable building of mozilla's HTML editor
+ <flag name='moznocompose'>Disable building of Mozilla's HTML editor
component</flag>
- <flag name='moznoirc'>Disable building of mozilla's IRC client</flag>
- <flag name='moznomail'>Disable building mozilla's mail client</flag>
+ <flag name='moznoirc'>Disable building of Mozilla's IRC client</flag>
+ <flag name='moznomail'>Disable building Mozilla's mail client</flag>
<flag name='moznopango'>Disable <pkg>x11-libs/pango</pkg> during
runtime</flag>
<flag name='moznoroaming'>sroaming extension support</flag>
- <flag name='xforms'>XForms is a standard to split up XHTML into XForms,
- instance data, and user interface</flag>
+
+ <!-- Other USE-flags -->
<flag name='custom-optimization'>Fine-tune custom compiler
optimizations</flag>
+ <flag name='system-sqlite'>Use the system-wide <pkg>dev-db/sqlite</pkg>
+ installation with secure-delete enabled</flag>
+ <flag name='xforms'>XForms is a standard to split up XHTML into XForms,
+ instance data, and user interface</flag>
</use>
</pkgmetadata>
diff --git a/www-client/seamonkey/seamonkey-2.0.3.ebuild b/www-client/seamonkey/seamonkey-2.0.3.ebuild
new file mode 100644
index 000000000000..28a43ef05f67
--- /dev/null
+++ b/www-client/seamonkey/seamonkey-2.0.3.ebuild
@@ -0,0 +1,277 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.0.3.ebuild,v 1.1 2010/03/04 14:51:31 nirbheek Exp $
+
+EAPI="2"
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib fdo-mime autotools mozextension java-pkg-opt-2
+
+PATCH="${PN}-2.0.3-patches-0.1"
+EMVER="1.0.1"
+
+LANGS="be ca cs de en-US es-AR es-ES fr gl hu it ja ka lt nb-NO nl pl pt-PT ru sk sv-SE tr"
+NOSHORTLANGS="es-AR es-ES nb-NO pt-PT sv-SE"
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Seamonkey Web Browser"
+HOMEPAGE="http://www.seamonkey-project.org"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="+alsa +chatzilla +composer +crypt java ldap +mailclient +roaming system-sqlite"
+
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/${PN}/releases"
+SRC_URI="${REL_URI}/${MY_PV}/source/${MY_P}.source.tar.bz2
+ http://dev.gentoo.org/~polynomial-c/${PATCH}.tar.bz2
+ crypt? ( mailclient? ( http://www.mozilla-enigmail.org/download/source/enigmail-${EMVER}.tar.gz ) )"
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/langpack/${MY_P}.${X}.langpack.xpi -> ${MY_P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( ${REL_URI}/${MY_PV}/langpack/${MY_P}.${X}.langpack.xpi -> ${MY_P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+RDEPEND="java? ( virtual/jre )
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.12.2
+ >=dev-libs/nspr-4.8
+ alsa? ( media-libs/alsa-lib )
+ system-sqlite? ( >=dev-db/sqlite-3.6.22-r2[fts3,secure-delete] )
+ >=app-text/hunspell-1.2
+ >=x11-libs/gtk+-2.10.0
+ >=x11-libs/cairo-1.8.8[X]
+ >=x11-libs/pango-1.14.0[X]
+ crypt? ( mailclient? ( >=app-crypt/gnupg-1.4 ) )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ java? ( >=virtual/jdk-1.4 )"
+
+S="${WORKDIR}/comm-1.9.1"
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+
+ linguas
+ for X in ${linguas}; do
+ # FIXME: Add support for unpacking xpis to portage
+ [[ ${X} != "en" ]] && xpi_unpack "${MY_P}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+pkg_setup() {
+ export BUILD_OFFICIAL=1
+ export MOZILLA_OFFICIAL=1
+
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ java-pkg-opt-2_src_prepare
+
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"
+
+ if use crypt && use mailclient ; then
+ mv "${WORKDIR}"/enigmail "${S}"/mailnews/extensions/enigmail
+ cd "${S}"/mailnews/extensions/enigmail || die
+ epatch "${FILESDIR}"/enigmail/70_enigmail-fix.patch
+ makemake2
+ cd "${S}"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ MEXTENSIONS=""
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ if ! use chatzilla ; then
+ MEXTENSIONS="${MEXTENSIONS},-irc"
+ fi
+ if ! use roaming ; then
+ MEXTENSIONS="${MEXTENSIONS},-sroaming"
+ fi
+
+ if ! use gnome ; then
+ MEXTENSIONS="${MEXTENSIONS},-gnomevfs"
+ fi
+
+ if ! use composer ; then
+ if ! use chatzilla && ! use mailclient ; then
+ mozconfig_annotate '-composer' --disable-composer
+ fi
+ fi
+
+ mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ mozconfig_annotate '' --enable-application=suite
+ mozconfig_annotate 'broken' --disable-mochitest
+ mozconfig_annotate 'broken' --disable-crashreporter
+ mozconfig_annotate '' --enable-system-hunspell
+ mozconfig_annotate '' --enable-jsd
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --enable-system-lcms
+ mozconfig_annotate '' --with-system-bz2
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate 'places' --enable-storage --enable-places --enable-places_bookmarks
+ mozconfig_annotate '' --disable-installer
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+
+ # Enable/Disable based on USE flags
+ mozconfig_use_enable alsa ogg
+ mozconfig_use_enable alsa wave
+ mozconfig_use_enable java javaxpcom
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_use_enable mailclient mailnews
+ mozconfig_use_enable system-sqlite
+
+ # Finalize and report settings
+ mozconfig_final
+
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ append-cxxflags -fno-stack-protector
+ fi
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ # Work around breakage in makeopts with --no-print-directory
+ MAKEOPTS="${MAKEOPTS/--no-print-directory/}"
+
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" econf
+}
+
+src_compile() {
+ # Should the build use multiprocessing? Not enabled by default, as it tends to break.
+ [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
+ emake ${jobs} || die
+
+ # Only build enigmail extension if conditions are met.
+ if use crypt && use mailclient ; then
+ emake -C "${S}"/mailnews/extensions/enigmail || die "make enigmail failed"
+ emake -j1 -C "${S}"/mailnews/extensions/enigmail xpi || die "make enigmail xpi failed"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ declare emid
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use crypt && use mailclient ; then
+ cd "${T}"
+ unzip "${S}"/mozilla/dist/bin/enigmail*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd "${D}"${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip "${S}"/mozilla/dist/bin/enigmail*.xpi
+ fi
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${MY_P}-${X}"
+ done
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/suite/branding/content/icon64.png seamonkey.png
+ domenu "${FILESDIR}"/icon/seamonkey.desktop
+
+ # Add StartupNotify=true bug 290401
+ if use startup-notification ; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/seamonkey.desktop
+ fi
+
+ # Add our default prefs
+ sed "s|SEAMONKEY_PVR|${PVR}|" "${FILESDIR}"/all-gentoo.js \
+ > "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-gentoo.js
+
+ # Plugins dir
+ rm -rf "${D}"${MOZILLA_FIVE_HOME}/plugins || die "failed to remove existing plugins dir"
+ dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins
+
+ # shiny new man page
+ doman "${S}"/suite/app/${PN}.1
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME="${ROOT}/usr/$(get_libdir)/${PN}"
+
+ if [ -d ${MOZILLA_FIVE_HOME}/plugins ] ; then
+ rm ${MOZILLA_FIVE_HOME}/plugins -rf
+ fi
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+
+ if use chatzilla ; then
+ elog "chatzilla is now an extension which can be en-/disabled and configured via"
+ elog "the Add-on manager."
+ fi
+}