summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2015-02-09 10:39:40 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2015-02-09 10:39:40 +0000
commit79d4787f391f32b346ee81e2a116abcdfde5a4e5 (patch)
tree0f774d1acc1d61ff3f1792f4941600cb51eed9a1 /www-client
parentNo ARM support for Widevine (diff)
downloadgentoo-2-79d4787f391f32b346ee81e2a116abcdfde5a4e5.tar.gz
gentoo-2-79d4787f391f32b346ee81e2a116abcdfde5a4e5.tar.bz2
gentoo-2-79d4787f391f32b346ee81e2a116abcdfde5a4e5.zip
Unbreak repoman
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog9
-rw-r--r--www-client/chromium/chromium-40.0.2214.111.ebuild26
-rw-r--r--www-client/chromium/chromium-40.0.2214.91.ebuild26
-rw-r--r--www-client/chromium/chromium-40.0.2214.93.ebuild26
-rw-r--r--www-client/chromium/chromium-41.0.2272.12-r1.ebuild26
-rw-r--r--www-client/chromium/chromium-41.0.2272.16.ebuild26
-rw-r--r--www-client/chromium/chromium-41.0.2272.35.ebuild26
-rw-r--r--www-client/chromium/chromium-42.0.2288.6.ebuild26
-rw-r--r--www-client/chromium/metadata.xml3
9 files changed, 171 insertions, 23 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 9fa4b4cfa77e..e8a41bd136ad 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1196 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1197 2015/02/09 10:39:40 zx2c4 Exp $
+
+ 09 Feb 2015; Jason A. Donenfeld <zx2c4@gentoo.org>
+ chromium-40.0.2214.111.ebuild, chromium-40.0.2214.91.ebuild,
+ chromium-40.0.2214.93.ebuild, chromium-41.0.2272.12-r1.ebuild,
+ chromium-41.0.2272.16.ebuild, chromium-41.0.2272.35.ebuild,
+ chromium-42.0.2288.6.ebuild, metadata.xml:
+ Unbreak repoman
09 Feb 2015; Mike Gilbert <floppym@gentoo.org> chromium-40.0.2214.111.ebuild,
chromium-40.0.2214.91.ebuild, chromium-40.0.2214.93.ebuild,
diff --git a/www-client/chromium/chromium-40.0.2214.111.ebuild b/www-client/chromium/chromium-40.0.2214.111.ebuild
index 6aca7777b907..dd7a4d56b316 100644
--- a/www-client/chromium/chromium-40.0.2214.111.ebuild
+++ b/www-client/chromium/chromium-40.0.2214.111.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.111.ebuild,v 1.4 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.111.ebuild,v 1.5 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -571,6 +588,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-40.0.2214.91.ebuild b/www-client/chromium/chromium-40.0.2214.91.ebuild
index 2af5b55b3348..1d2749f151df 100644
--- a/www-client/chromium/chromium-40.0.2214.91.ebuild
+++ b/www-client/chromium/chromium-40.0.2214.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.91.ebuild,v 1.5 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.91.ebuild,v 1.6 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -571,6 +588,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-40.0.2214.93.ebuild b/www-client/chromium/chromium-40.0.2214.93.ebuild
index 9550de87d5ea..96740154fe2a 100644
--- a/www-client/chromium/chromium-40.0.2214.93.ebuild
+++ b/www-client/chromium/chromium-40.0.2214.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.93.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.93.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -571,6 +588,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-41.0.2272.12-r1.ebuild b/www-client/chromium/chromium-41.0.2272.12-r1.ebuild
index 2af05c72656f..ed63c55d04fb 100644
--- a/www-client/chromium/chromium-41.0.2272.12-r1.ebuild
+++ b/www-client/chromium/chromium-41.0.2272.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.12-r1.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.12-r1.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -575,6 +592,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-41.0.2272.16.ebuild b/www-client/chromium/chromium-41.0.2272.16.ebuild
index 7f8b21e37f98..dd5e1d54e54d 100644
--- a/www-client/chromium/chromium-41.0.2272.16.ebuild
+++ b/www-client/chromium/chromium-41.0.2272.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.16.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.16.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -575,6 +592,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-41.0.2272.35.ebuild b/www-client/chromium/chromium-41.0.2272.35.ebuild
index 2367617f9a3c..0e2d5c2bf7a8 100644
--- a/www-client/chromium/chromium-41.0.2272.35.ebuild
+++ b/www-client/chromium/chromium-41.0.2272.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.35.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-41.0.2272.35.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -575,6 +592,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/chromium-42.0.2288.6.ebuild b/www-client/chromium/chromium-42.0.2288.6.ebuild
index 373f965f1278..6d30cb922714 100644
--- a/www-client/chromium/chromium-42.0.2288.6.ebuild
+++ b/www-client/chromium/chromium-42.0.2288.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-42.0.2288.6.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-42.0.2288.6.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring hidpi kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -95,7 +95,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -188,6 +192,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-libsecret-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -577,6 +594,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/metadata.xml b/www-client/chromium/metadata.xml
index 97dfb1f43a68..018308b7cd6f 100644
--- a/www-client/chromium/metadata.xml
+++ b/www-client/chromium/metadata.xml
@@ -7,6 +7,7 @@
<flag name="bindist">Disable patent-encumbered HTML5 video codecs</flag>
<flag name="hidpi">Enable support for high-resolution screens (high dots per inch)</flag>
<flag name="pic">Disable optimized assembly code that is not PIC friendly</flag>
- <flag name="tcmalloc">Use bundled tcmalloc instead of system malloc.</flag>
+ <flag name="tcmalloc">Use bundled tcmalloc instead of system malloc</flag>
+ <flag name="widevine">Support the Widevine DRM module from www-plugins/chrome-binary-plugins</flag>
</use>
</pkgmetadata>