summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-10-13 18:15:22 +0000
committerAlex Alexander <wired@gentoo.org>2012-10-13 18:15:22 +0000
commitf325a92702fe964fb06c18ad803617e1bf505294 (patch)
tree648572abd9a91656405e7f4e426cd223f206eab7 /www-client
parentRemove old. (diff)
downloadgentoo-2-f325a92702fe964fb06c18ad803617e1bf505294.tar.gz
gentoo-2-f325a92702fe964fb06c18ad803617e1bf505294.tar.bz2
gentoo-2-f325a92702fe964fb06c18ad803617e1bf505294.zip
version bump, sync with live ebuild. bugs fixed: #412843 #416175 #420565 and #434084
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/uget/ChangeLog9
-rw-r--r--www-client/uget/uget-1.10.2.ebuild82
-rw-r--r--www-client/uget/uget-9999.ebuild52
3 files changed, 116 insertions, 27 deletions
diff --git a/www-client/uget/ChangeLog b/www-client/uget/ChangeLog
index cbab8e917aba..24f54574e76e 100644
--- a/www-client/uget/ChangeLog
+++ b/www-client/uget/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/uget
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.32 2012/09/06 05:42:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.33 2012/10/13 18:15:22 wired Exp $
+
+*uget-1.10.2 (13 Oct 2012)
+
+ 13 Oct 2012; Alex Alexander <wired@gentoo.org> +uget-1.10.2.ebuild,
+ uget-9999.ebuild:
+ version bump, sync with live ebuild. bugs fixed: #412843 #416175 #420565 and
+ #434084
06 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> -uget-1.7.0.ebuild,
-files/uget-1.7.0-as-needed.patch, -uget-1.7.3.ebuild, -uget-1.7.4.ebuild,
diff --git a/www-client/uget/uget-1.10.2.ebuild b/www-client/uget/uget-1.10.2.ebuild
new file mode 100644
index 000000000000..1629ba5fcf10
--- /dev/null
+++ b/www-client/uget/uget-1.10.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.10.2.ebuild,v 1.1 2012/10/13 18:15:22 wired Exp $
+
+EAPI="4"
+
+IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-2
+ KEYWORDS=""
+ SRC_URI=""
+ EGIT_REPO_URI="git://urlget.git.sourceforge.net/gitroot/urlget/uget"
+else
+ KEYWORDS="~amd64 ~ppc ~x86"
+ SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+fi
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://urlget.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+REQUIRED_USE="|| ( aria2 curl )"
+
+RDEPEND="
+ dev-libs/libpcre
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4:3
+ curl? ( >=net-misc/curl-7.10 )
+ gstreamer? ( media-libs/gstreamer )
+ libnotify? ( x11-libs/libnotify )
+ "
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ intltoolize || die "intltoolize failed"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf $(use_enable nls) \
+ $(use_enable curl plugin-curl) \
+ $(use_enable aria2 plugin-aria2) \
+ $(use_enable gstreamer) \
+ $(use_enable hide-temp-files hidden) \
+ $(use_enable libnotify notify)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the build system forgets this :p
+ dobin uget-cmd/uget-cmd
+
+ if [[ ${PV} == *9999* ]]; then
+ dodoc AUTHORS ChangeLog README
+ else
+ dodoc AUTHORS ChangeLog NEWS README
+ fi
+}
+
+pkg_postinst() {
+ if use aria2; then
+ echo
+ elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
+ elog "built. This allows you to control a local or remote instance of aria2"
+ elog "through xmlrpc. To use aria2 locally you have to emerge"
+ elog "net-misc/aria2 with the xmlrpc USE enabled manually."
+ echo
+ fi
+}
diff --git a/www-client/uget/uget-9999.ebuild b/www-client/uget/uget-9999.ebuild
index 82cc2383f041..bf71b0aa8a4a 100644
--- a/www-client/uget/uget-9999.ebuild
+++ b/www-client/uget/uget-9999.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-9999.ebuild,v 1.6 2012/05/03 06:01:03 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-9999.ebuild,v 1.7 2012/10/13 18:15:22 wired Exp $
EAPI="4"
-inherit autotools git-2
+IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-2
+ KEYWORDS=""
+ SRC_URI=""
+ EGIT_REPO_URI="git://urlget.git.sourceforge.net/gitroot/urlget/uget"
+else
+ KEYWORDS="~amd64 ~ppc ~x86"
+ SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+fi
DESCRIPTION="Download manager using gtk+ and libcurl"
HOMEPAGE="http://urlget.sourceforge.net/"
-SRC_URI=""
-
-EGIT_REPO_URI="git://urlget.git.sourceforge.net/gitroot/urlget/uget"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE="aria2 +curl gstreamer gtk3 hide-temp-files libnotify nls"
REQUIRED_USE="|| ( aria2 curl )"
RDEPEND="
dev-libs/libpcre
- >=dev-libs/glib-2:2
- !gtk3? (
- >=x11-libs/gtk+-2.18:2
- )
- gtk3? (
- x11-libs/gtk+:3
- )
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4:3
curl? ( >=net-misc/curl-7.10 )
gstreamer? ( media-libs/gstreamer )
libnotify? ( x11-libs/libnotify )
@@ -38,23 +37,20 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
src_prepare() {
- # add missing file, fix tests, bug #376203
- echo "uglib/UgPlugin-aria2.c" >> po/POTFILES.in ||
- die "echo in po/POTFILES.in failed"
-
- eautoreconf
- intltoolize || die "intltoolize failed"
- eautoreconf
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ intltoolize || die "intltoolize failed"
+ eautoreconf
+ fi
}
src_configure() {
econf $(use_enable nls) \
- $(use_with gtk3) \
$(use_enable curl plugin-curl) \
$(use_enable aria2 plugin-aria2) \
$(use_enable gstreamer) \
$(use_enable hide-temp-files hidden) \
- $(use_enable libnotify notify) || die "econf failed"
+ $(use_enable libnotify notify)
}
src_compile() {
@@ -62,12 +58,16 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
# the build system forgets this :p
- dobin uget-cmd/uget-cmd || die "uget-cmd install failed"
+ dobin uget-cmd/uget-cmd
- dodoc AUTHORS ChangeLog README || die "dodoc failed"
+ if [[ ${PV} == *9999* ]]; then
+ dodoc AUTHORS ChangeLog README
+ else
+ dodoc AUTHORS ChangeLog NEWS README
+ fi
}
pkg_postinst() {