summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-04-30 09:05:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-04-30 09:05:21 +0000
commit10231aa019e4d0de337075b61419d8633dbb3b91 (patch)
tree7634a4d8fd5e5d1fe7c029e987e278a75fee5a54 /www-servers/fnord
parentApply as --divide fix for Intel-based Solaris only to unbreak Sparc-based (diff)
downloadgentoo-2-10231aa019e4d0de337075b61419d8633dbb3b91.tar.gz
gentoo-2-10231aa019e4d0de337075b61419d8633dbb3b91.tar.bz2
gentoo-2-10231aa019e4d0de337075b61419d8633dbb3b91.zip
Bump, add amd64 keyword
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers/fnord')
-rw-r--r--www-servers/fnord/ChangeLog7
-rw-r--r--www-servers/fnord/fnord-1.11.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/www-servers/fnord/ChangeLog b/www-servers/fnord/ChangeLog
index b9914b47d22f..3c8b7ed7eba3 100644
--- a/www-servers/fnord/ChangeLog
+++ b/www-servers/fnord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/fnord
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/fnord/ChangeLog,v 1.29 2014/01/08 06:08:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/fnord/ChangeLog,v 1.30 2014/04/30 09:05:21 patrick Exp $
+
+*fnord-1.11 (30 Apr 2014)
+
+ 30 Apr 2014; Patrick Lauer <patrick@gentoo.org> +fnord-1.11.ebuild:
+ Bump, add amd64 keyword
08 Jan 2014; Mike Frysinger <vapier@gentoo.org> fnord-1.10-r2.ebuild:
Inherit the user eclass for enewuser/etc...
diff --git a/www-servers/fnord/fnord-1.11.ebuild b/www-servers/fnord/fnord-1.11.ebuild
new file mode 100644
index 000000000000..24b9b925afba
--- /dev/null
+++ b/www-servers/fnord/fnord-1.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/fnord/fnord-1.11.ebuild,v 1.1 2014/04/30 09:05:21 patrick Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs user
+
+DESCRIPTION="Yet another small httpd."
+HOMEPAGE="http://www.fefe.de/fnord/"
+SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="auth"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp"
+
+pkg_setup() {
+ enewgroup nofiles 200
+ enewuser fnord -1 -1 /etc/fnord nofiles
+ enewuser fnordlog -1 -1 /etc/fnord nofiles
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}"-1.10-gentoo.diff
+}
+
+src_compile() {
+ # Fix for bug #45716
+ replace-sparc64-flags
+
+ use auth && \
+ append-flags -DAUTH
+
+ emake DIET="" CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ dobin fnord-conf fnord || die
+ dodoc TODO README* SPEED CHANGES
+}