summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-26 13:50:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-26 13:50:48 +0000
commit1a2eafe5cc699692c2e534273d0ef57ce16a5127 (patch)
tree12e06baf8945fb8ad9f959c9e63aebfe2a0b4f29 /www-servers/orion
parentUsing -pPR instead -a option in cp, bug #103487 (diff)
downloadgentoo-2-1a2eafe5cc699692c2e534273d0ef57ce16a5127.tar.gz
gentoo-2-1a2eafe5cc699692c2e534273d0ef57ce16a5127.tar.bz2
gentoo-2-1a2eafe5cc699692c2e534273d0ef57ce16a5127.zip
Don't specify root group as it doesn't exists on BSD-like userlands. Replace cp -a to cp -pPR (where it makes sense). Use newinitd/newconfd instead of copying and installing files around.
(Portage version: 2.0.51.22)
Diffstat (limited to 'www-servers/orion')
-rw-r--r--www-servers/orion/ChangeLog7
-rw-r--r--www-servers/orion/orion-2.0.5.ebuild19
2 files changed, 12 insertions, 14 deletions
diff --git a/www-servers/orion/ChangeLog b/www-servers/orion/ChangeLog
index 5e65fe20563f..2f7db7cd3e04 100644
--- a/www-servers/orion/ChangeLog
+++ b/www-servers/orion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/orion
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/ChangeLog,v 1.9 2005/06/24 22:33:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/ChangeLog,v 1.10 2005/08/26 13:50:48 flameeyes Exp $
+
+ 26 Aug 2005; Diego Pettenò <flameeyes@gentoo.org> orion-2.0.5.ebuild:
+ Don't specify root group as it doesn't exists on BSD-like userlands. Replace
+ cp -a to cp -pPR (where it makes sense). Use newinitd/newconfd instead of
+ copying and installing files around.
24 Jun 2005; Aron Griffis <agriffis@gentoo.org> orion-2.0.1.ebuild,
orion-2.0.2.ebuild, orion-2.0.5.ebuild:
diff --git a/www-servers/orion/orion-2.0.5.ebuild b/www-servers/orion/orion-2.0.5.ebuild
index 328905632963..c0ddea895234 100644
--- a/www-servers/orion/orion-2.0.5.ebuild
+++ b/www-servers/orion/orion-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.6 2005/07/18 23:59:33 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.7 2005/08/26 13:50:48 flameeyes Exp $
inherit eutils java-pkg
@@ -40,15 +40,8 @@ src_install() {
doins ${FILESDIR}/${PV}/start_orion.sh
doins ${FILESDIR}/${PV}/stop_orion.sh
- cp -a ${FILESDIR}/${PV}/orion.init ${S}/orion
- insinto /etc/init.d
- insopts -m0750
- doins ${S}/orion
-
- cp -a ${FILESDIR}/${PV}/orion.conf ${S}/orion
- insinto /etc/conf.d
- insopts -m0750
- doins ${S}/orion
+ newinitd ${FILESDIR}/${PV}/orion.init orion
+ newconfd ${FILESDIR}/${PV}/orion.conf orion
# CREATE DUMMY LOG & PERSISTENCE DIR
dodir /var/log/${PN}
@@ -60,14 +53,14 @@ src_install() {
# INSTALL EXTRA FILES
local dirs="applications default-web-app demo lib persistence autoupdate.properties"
for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/
+ cp -pPR ${i} ${D}/opt/${PN}/
done
# INSTALL APP CONFIG
cd ${S}/config
local dirs="application.xml data-sources.xml database-schemas default-web-site.xml global-web-application.xml jms.xml mime.types principals.xml rmi.xml server.xml"
for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/config
+ cp -pPR ${i} ${D}/opt/${PN}/config
done
# INSTALL JARS
@@ -88,7 +81,7 @@ pkg_preinst() {
enewuser orion -1 /bin/bash /opt/orion orion
chown -R orion:orion ${IMAGE}/opt/${PN}
chown -R orion:orion ${IMAGE}/var/log/${PN}
- chown root:root ${IMAGE}/etc/conf.d/orion
+ chown root:0 ${IMAGE}/etc/conf.d/orion
}
pkg_postinst() {