summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-09 21:49:34 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-09 21:49:34 +0000
commit2782064db11db1825a22656253c6171db00f5279 (patch)
tree5fcfaf72ab82621afc2b72ee697527d61e0bf185 /www-servers/resin
parentversion bump (see bug #225485). (diff)
downloadgentoo-2-2782064db11db1825a22656253c6171db00f5279.tar.gz
gentoo-2-2782064db11db1825a22656253c6171db00f5279.tar.bz2
gentoo-2-2782064db11db1825a22656253c6171db00f5279.zip
Fix root-directory issue, see bug #222865.
(Portage version: 2.1.5.4)
Diffstat (limited to 'www-servers/resin')
-rw-r--r--www-servers/resin/ChangeLog8
-rw-r--r--www-servers/resin/files/3.1.6/resin.init4
-rw-r--r--www-servers/resin/resin-3.1.6-r1.ebuild (renamed from www-servers/resin/resin-3.1.6.ebuild)4
3 files changed, 12 insertions, 4 deletions
diff --git a/www-servers/resin/ChangeLog b/www-servers/resin/ChangeLog
index 650638b23cf7..e56013a52c9b 100644
--- a/www-servers/resin/ChangeLog
+++ b/www-servers/resin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/resin
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/ChangeLog,v 1.76 2008/05/12 09:37:31 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/ChangeLog,v 1.77 2008/06/09 21:49:33 nelchael Exp $
+
+*resin-3.1.6-r1 (09 Jun 2008)
+
+ 09 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org> files/3.1.6/resin.init,
+ -resin-3.1.6.ebuild, +resin-3.1.6-r1.ebuild:
+ Fix root-directory issue, see bug #222865.
12 May 2008; Krzysiek Pawlik <nelchael@gentoo.org> resin-3.1.6.ebuild:
Add ~ppc keyword.
diff --git a/www-servers/resin/files/3.1.6/resin.init b/www-servers/resin/files/3.1.6/resin.init
index 846fd9201aeb..3e54973b2835 100644
--- a/www-servers/resin/files/3.1.6/resin.init
+++ b/www-servers/resin/files/3.1.6/resin.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/files/3.1.6/resin.init,v 1.1 2008/05/10 20:17:12 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/files/3.1.6/resin.init,v 1.2 2008/06/09 21:49:34 nelchael Exp $
depend() {
need net
@@ -22,7 +22,7 @@ runResin() {
local msg="${1}"
shift
- local cmdline="${JAVA_HOME}/bin/java -jar /usr/share/resin/lib/resin.jar -conf /etc/resin/resin.conf -resin-home /usr/lib/resin ${extraArgs} ${@}"
+ local cmdline="${JAVA_HOME}/bin/java -jar /usr/share/resin/lib/resin.jar -conf /etc/resin/resin.conf -resin-home __RESIN_HOME__ -root-directory __RESIN_HOME__ ${extraArgs} ${@}"
ebegin "${msg}"
su - resin -c "${cmdline}"
diff --git a/www-servers/resin/resin-3.1.6.ebuild b/www-servers/resin/resin-3.1.6-r1.ebuild
index 73cc4bbf4cf6..22028a754521 100644
--- a/www-servers/resin/resin-3.1.6.ebuild
+++ b/www-servers/resin/resin-3.1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/resin-3.1.6.ebuild,v 1.4 2008/05/12 09:37:31 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/resin-3.1.6-r1.ebuild,v 1.1 2008/06/09 21:49:33 nelchael Exp $
EAPI="1"
@@ -118,6 +118,8 @@ src_install() {
newinitd "${FILESDIR}/${PV}/resin.init" resin
newconfd "${FILESDIR}/${PV}/resin.conf" resin
+ sed -i -e "s,__RESIN_HOME__,${RESIN_HOME},g" "${D}/etc/init.d/resin"
+
rm -f "${S}/lib/tools.jar"
java-pkg_dojar "${S}"/lib/*.jar
rm -fr "${D}/${RESIN_HOME}/lib"