summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2014-05-13 00:56:10 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2014-05-13 00:56:10 +0000
commit142d4d316000bf27149b8161a679322dcfbd02f5 (patch)
tree0f7c204a82ede2155680d84bf611e8d27609b923 /www-servers
parentFix COMMON_DEPEND (bug #510196, thanks to Ben Kohler). (diff)
downloadgentoo-2-142d4d316000bf27149b8161a679322dcfbd02f5.tar.gz
gentoo-2-142d4d316000bf27149b8161a679322dcfbd02f5.tar.bz2
gentoo-2-142d4d316000bf27149b8161a679322dcfbd02f5.zip
Migrated to distutils-r1 by jbergstroem
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-18.0-r1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 05af2b0ea687..782ffd8a1d8f 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.34 2014/03/03 23:31:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.35 2014/05/13 00:56:10 rafaelmartins Exp $
+
+*gunicorn-18.0-r1 (13 May 2014)
+
+ 13 May 2014; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-18.0-r1.ebuild:
+ Migrated to distutils-r1 by jbergstroem
03 Mar 2014; Pacho Ramos <pacho@gentoo.org> gunicorn-0.17.4.ebuild:
amd64 stable, bug #474322
diff --git a/www-servers/gunicorn/gunicorn-18.0-r1.ebuild b/www-servers/gunicorn/gunicorn-18.0-r1.ebuild
new file mode 100644
index 000000000000..fafe2ac2ccc9
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-18.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-18.0-r1.ebuild,v 1.1 2014/05/13 00:56:10 rafaelmartins Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS="README.rst"
+
+python_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+}