summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-03-19 16:44:08 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-03-19 16:44:08 +0000
commit5f6977fb33ef6e69418f7c0e801a667173fa51de (patch)
tree2d1432a8c6ec823cca7623fae7b45f3808c8e41c /www-servers
parentupdated to gnbd-kernel-2.6.9-8 (diff)
downloadgentoo-2-5f6977fb33ef6e69418f7c0e801a667173fa51de.tar.gz
gentoo-2-5f6977fb33ef6e69418f7c0e801a667173fa51de.tar.bz2
gentoo-2-5f6977fb33ef6e69418f7c0e801a667173fa51de.zip
bump!
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.251
-rw-r--r--www-servers/nginx/nginx-0.1.25.ebuild88
4 files changed, 98 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 694311e8e87f..2c24f6e9ee54 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.7 2005/03/13 13:40:03 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.8 2005/03/19 16:44:08 voxus Exp $
+
+*nginx-0.1.25 (19 Mar 2005)
+
+ 19 Mar 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.25.ebuild:
+ Version bump.
13 Mar 2005; Konstantin Arkhipov <voxus@gentoo.org> -nginx-0.1.24-r1-ebuild:
Clean up a bit.
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index e208afefe871..bd82d81e0a25 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,7 +1,9 @@
MD5 9e2c09a3e7cce1849c7a96c703bb9c5f nginx-0.1.24-r2.ebuild 2516
-MD5 21b46d8a32ed9dc9eb03823a38093a44 ChangeLog 1253
+MD5 ac27e5c6d6129d16e30c73f24a8ae355 nginx-0.1.25.ebuild 2420
+MD5 baeeb799d60085edf1a580b9e7d709e2 ChangeLog 1375
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 f74a821fb78c52685c73508de91ccc07 files/nginx-0.1.24-upstream_status.patch 566
+MD5 10ab54673f080934c259672c08995f4d files/digest-nginx-0.1.25 64
MD5 8c7b8c93f0c4048d83df9cdc31d86e1b files/nginx 922
MD5 4b6dd57dc730704d18f0b41e3ef2e3ec files/digest-nginx-0.1.24-r2 64
MD5 b3342c18a1880b574cbe4458560019c6 files/nginx.conf 1445
diff --git a/www-servers/nginx/files/digest-nginx-0.1.25 b/www-servers/nginx/files/digest-nginx-0.1.25
new file mode 100644
index 000000000000..3ff28581fae1
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.25
@@ -0,0 +1 @@
+MD5 afc92d951b2b024328d7a0d9002a2ac2 nginx-0.1.25.tar.gz 291125
diff --git a/www-servers/nginx/nginx-0.1.25.ebuild b/www-servers/nginx/nginx-0.1.25.ebuild
new file mode 100644
index 000000000000..3fd75cf012b5
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.25.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.25.ebuild,v 1.1 2005/03/19 16:44:08 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl zlib threads"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+
+# use charset-mod || myconf = "${myconf} --without-http_charset_module"
+# use userid-mod || myconf = "${myconf} --without-http_userid_module"
+# use access-mod || myconf = "${myconf} --without-http_access_module"
+# use autoindex-mod || myconf = "${myconf} --without-http_autoindex_module"
+# use geo-mod || myconf = "${myconf} --without-http_geo_module"
+# use rewrite-mod || myconf = "${myconf} --without-http_rewrite_module"
+# use proxy-mod || myconf = "${myconf} --without-http_proxy_module"
+# use fastcgi-mod || myconf = "${myconf} --without-http_fastcgi_module"
+
+ cd ${S}
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf}
+
+ emake || "failed to compile"
+}
+
+src_install() {
+ cd ${S} || die
+
+ dodir /var/log/${PN}
+ keepdir /var/log/${PN}
+
+ dodir /var/tmp/${PN}
+
+ dodir /var/tmp/${PN}/client
+ keepdir /var/tmp/${PN}/client
+
+ dodir /var/tmp/${PN}/proxy
+ keepdir /var/tmp/${PN}/proxy
+
+ dodir /var/tmp/${PN}/fastcgi
+ keepdir /var/tmp/${PN}/fastcgi
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}