summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-11 20:14:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-11 20:14:39 +0000
commit36af6e73cf4f95237eaab5c2bf54fe02f441a010 (patch)
treecc7284d6d748bcbca727810f934c2f92586c16d8 /x11-apps/simple-ccsm
parentDelete older ebuild. (diff)
downloadgentoo-2-36af6e73cf4f95237eaab5c2bf54fe02f441a010.tar.gz
gentoo-2-36af6e73cf4f95237eaab5c2bf54fe02f441a010.tar.bz2
gentoo-2-36af6e73cf4f95237eaab5c2bf54fe02f441a010.zip
Use Python 2 (bug #316987), delete useless "gtk" USE flag, improve usage of gnome2-utils.eclass.
(Portage version: 2.2.0_alpha29_p12/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/simple-ccsm')
-rw-r--r--x11-apps/simple-ccsm/ChangeLog9
-rw-r--r--x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild31
2 files changed, 30 insertions, 10 deletions
diff --git a/x11-apps/simple-ccsm/ChangeLog b/x11-apps/simple-ccsm/ChangeLog
index ceded4ae055e..a5eeffed1b9d 100644
--- a/x11-apps/simple-ccsm/ChangeLog
+++ b/x11-apps/simple-ccsm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/simple-ccsm
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.10 2010/04/03 05:28:03 jmbsvicetto Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.11 2011/04/11 20:14:39 arfrever Exp $
+
+ 11 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ simple-ccsm-0.8.4-r1.ebuild:
+ Use Python 2 (bug #316987), delete useless "gtk" USE flag, improve usage of
+ gnome2-utils.eclass.
*simple-ccsm-0.8.4-r1 (03 Apr 2010)
diff --git a/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild
index 0496c15fc804..dbf206f42da3 100644
--- a/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild
+++ b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild,v 1.1 2010/04/03 05:28:03 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild,v 1.2 2011/04/11 20:14:39 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils gnome2-utils
@@ -11,14 +14,19 @@ SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="gtk"
+IUSE=""
RDEPEND="
>=dev-python/compizconfig-python-${PV}
- >=dev-python/pygtk-2.10
+ >=dev-python/pygtk-2.10:2
>=x11-apps/ccsm-${PV}
"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_compile() {
distutils_src_compile --prefix=/usr
}
@@ -27,9 +35,16 @@ src_install() {
distutils_src_install --prefix=/usr
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- if use gtk; then
- gnome2_icon_savelist
- gnome2_icon_cache_update
- fi
+ distutils_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_icon_cache_update
}