summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-10-07 10:16:59 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-10-07 10:16:59 +0000
commit0877e419ac6bac6a34ac187b5c36ba1fae4dd2fc (patch)
treef80f7a1b9716d77759ead460ab91b6985c98440e /x11-apps/xfs
parentstable arm, bug #194721 (diff)
downloadgentoo-2-0877e419ac6bac6a34ac187b5c36ba1fae4dd2fc.tar.gz
gentoo-2-0877e419ac6bac6a34ac187b5c36ba1fae4dd2fc.tar.bz2
gentoo-2-0877e419ac6bac6a34ac187b5c36ba1fae4dd2fc.zip
(#194606) Security bump.
(Portage version: 2.1.3.12)
Diffstat (limited to 'x11-apps/xfs')
-rw-r--r--x11-apps/xfs/ChangeLog7
-rw-r--r--x11-apps/xfs/files/digest-xfs-1.0.53
-rw-r--r--x11-apps/xfs/xfs-1.0.5.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/x11-apps/xfs/ChangeLog b/x11-apps/xfs/ChangeLog
index ab53f63f0ccf..eb64f305c1a9 100644
--- a/x11-apps/xfs/ChangeLog
+++ b/x11-apps/xfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.40 2007/10/04 14:18:50 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.41 2007/10/07 10:16:59 dberkholz Exp $
+
+*xfs-1.0.5 (07 Oct 2007)
+
+ 07 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; +xfs-1.0.5.ebuild:
+ (#194606) Security bump.
04 Oct 2007; Steve Dibb <beandog@gentoo.org> xfs-1.0.4-r1.ebuild:
amd64 stable, security bug 185660
diff --git a/x11-apps/xfs/files/digest-xfs-1.0.5 b/x11-apps/xfs/files/digest-xfs-1.0.5
new file mode 100644
index 000000000000..218f724f6322
--- /dev/null
+++ b/x11-apps/xfs/files/digest-xfs-1.0.5
@@ -0,0 +1,3 @@
+MD5 3fc73b5e39a1fe8b8d96563c8144cffe xfs-1.0.5.tar.bz2 152131
+RMD160 9e95f914e1813c9a1b78e19608ac5c0bab61784d xfs-1.0.5.tar.bz2 152131
+SHA256 f586f2101d42e512e7d20a6a6715c3c2cad19cacbee3b4034a0818de349e38f9 xfs-1.0.5.tar.bz2 152131
diff --git a/x11-apps/xfs/xfs-1.0.5.ebuild b/x11-apps/xfs/xfs-1.0.5.ebuild
new file mode 100644
index 000000000000..f174b8911afd
--- /dev/null
+++ b/x11-apps/xfs/xfs-1.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-1.0.5.ebuild,v 1.1 2007/10/07 10:16:59 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X font server"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND="x11-apps/ttmkfdir
+ x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6) --libdir=/etc"
+
+pkg_setup() {
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^configdir =.*:configdir = \$(sysconfdir)/X11/fs:g" \
+ "${S}"/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins "${FILESDIR}"/xfs.config config
+ newinitd "${FILESDIR}"/xfs.start xfs
+ newconfd "${FILESDIR}"/xfs.conf.d xfs
+}