summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-04-13 10:05:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-04-13 10:05:15 +0000
commitb9f396733a0c50b512ccb4af3277f3963b4a01f3 (patch)
tree22d3ccda2693ce70a06d8f4b6b56c9c139148625 /x11-apps
parentVersion bump to 1.8 release. (diff)
downloadgentoo-2-b9f396733a0c50b512ccb4af3277f3963b4a01f3.tar.gz
gentoo-2-b9f396733a0c50b512ccb4af3277f3963b4a01f3.tar.bz2
gentoo-2-b9f396733a0c50b512ccb4af3277f3963b4a01f3.zip
Add xinit version that accomodates 1.8 release
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/xinit-1.2.1-r1.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 4c4d9345e99f..1aeab2a82a41 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.180 2010/03/17 15:41:39 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.181 2010/04/13 10:05:15 scarabeus Exp $
+
+*xinit-1.2.1-r1 (13 Apr 2010)
+
+ 13 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +xinit-1.2.1-r1.ebuild:
+ Add xinit version that accomodates 1.8 release
*xinit-1.2.1 (17 Mar 2010)
diff --git a/x11-apps/xinit/xinit-1.2.1-r1.ebuild b/x11-apps/xinit/xinit-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..906bc4c33932
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.2.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.2.1-r1.ebuild,v 1.1 2010/04/13 10:05:15 scarabeus Exp $
+
+EAPI="2"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+minimal pam"
+
+RDEPEND="
+ x11-apps/xauth
+ >=x11-base/xorg-server-1.8.0
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-specific-customizations.patch"
+)
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="--with-xinitdir=/etc/X11/xinit"
+}
+
+src_install() {
+ x-modular_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc || die
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}