summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:32:36 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:32:36 +0000
commit0c2536f5655e5d4fad89986a4f0109237f5e7984 (patch)
treebaf7d86250148b832185842ec060d2c4e3308f43 /x11-drivers/ati-drivers
parentversion bump (diff)
downloadgentoo-2-0c2536f5655e5d4fad89986a4f0109237f5e7984.tar.gz
gentoo-2-0c2536f5655e5d4fad89986a4f0109237f5e7984.tar.bz2
gentoo-2-0c2536f5655e5d4fad89986a4f0109237f5e7984.zip
Drop opencl use flag and install OpenCL unconditionally
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/ati-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog6
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild28
2 files changed, 17 insertions, 17 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index a37c39b14b5b..aa1ab0814df7 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.271 2012/02/04 11:15:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.272 2012/02/04 12:32:36 xarthisius Exp $
+
+ 04 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ ati-drivers-12.1-r1.ebuild:
+ Drop opencl use flag and install OpenCL unconditionally
*ati-drivers-12.1-r1 (04 Feb 2012)
diff --git a/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild b/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild
index ac03276ad7a8..92675b5553c4 100644
--- a/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild,v 1.1 2012/02/04 11:15:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-12.1-r1.ebuild,v 1.2 2012/02/04 12:32:36 xarthisius Exp $
EAPI=4
@@ -17,7 +17,7 @@ else
SRC_URI="https://launchpad.net/ubuntu/natty/+source/fglrx-installer/2:${PV}-0ubuntu1/+files/fglrx-installer_${PV}.orig.tar.gz"
FOLDER_PREFIX=""
fi
-IUSE="debug +modules multilib opencl pax_kernel qt4"
+IUSE="debug +modules multilib pax_kernel qt4"
LICENSE="AMD GPL-2 QPL-1.0 as-is"
KEYWORDS="~amd64 ~x86"
@@ -428,7 +428,7 @@ src_install() {
into /opt
dosbin "${ARCH_DIR}"/usr/sbin/atieventsd
use qt4 && dosbin "${ARCH_DIR}"/usr/sbin/amdnotifyui
- use opencl && dobin "${ARCH_DIR}"/usr/bin/clinfo
+ dobin "${ARCH_DIR}"/usr/bin/clinfo
# We cleaned out the compilable stuff in src_unpack
dobin "${ARCH_DIR}"/usr/X11R6/bin/*
@@ -534,23 +534,19 @@ src_install-libs() {
doexe "${MY_ARCH_DIR}"/usr/X11R6/${pkglibdir}/modules/dri/fglrx_dri.so
# AMD Cal and OpenCL libraries
- if use opencl ; then
- exeinto /usr/$(get_libdir)/OpenCL/vendors/amd
- doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/libamdocl*.so*
- doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/libOpenCL*.so*
- dosym libOpenCL.so.${libmajor} /usr/$(get_libdir)/OpenCL/vendors/amd/libOpenCL.so
- fi
+ exeinto /usr/$(get_libdir)/OpenCL/vendors/amd
+ doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/libamdocl*.so*
+ doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/libOpenCL*.so*
+ dosym libOpenCL.so.${libmajor} /usr/$(get_libdir)/OpenCL/vendors/amd/libOpenCL.so
exeinto /usr/$(get_libdir)
doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/libati*.so*
# OpenCL vendor files
- if use opencl ; then
- insinto /etc/OpenCL/vendors/
- cat > "${T}"/amdocl${oclsuffix}.icd <<-EOF
- /usr/$(get_libdir)/OpenCL/vendors/amd/libamdocl${oclsuffix}.so
- EOF
- doins "${T}"/amdocl${oclsuffix}.icd
- fi
+ insinto /etc/OpenCL/vendors/
+ cat > "${T}"/amdocl${oclsuffix}.icd <<-EOF
+ /usr/$(get_libdir)/OpenCL/vendors/amd/libamdocl${oclsuffix}.so
+ EOF
+ doins "${T}"/amdocl${oclsuffix}.icd
local envname="${T}"/04ati-dri-path
if [[ -n ${ABI} ]]; then