summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-13 20:10:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-13 20:10:43 +0000
commitedb141eef836f102cbe3d9a633878d5811c56df7 (patch)
tree5d8b3d74ee7e7e29b860d336c0393e0550f28ee0 /x11-drivers/psb-kmod
parentInitial import of the intel poulsbo graphics driver and support libs. Fixes #... (diff)
downloadgentoo-2-edb141eef836f102cbe3d9a633878d5811c56df7.tar.gz
gentoo-2-edb141eef836f102cbe3d9a633878d5811c56df7.tar.bz2
gentoo-2-edb141eef836f102cbe3d9a633878d5811c56df7.zip
Initial import of the intel poulsbo graphics driver and support libs. Fixes #274184. Thanks to Konrad Campowsky for the ebuilds and all the people who tested them.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/psb-kmod')
-rw-r--r--x11-drivers/psb-kmod/ChangeLog12
-rw-r--r--x11-drivers/psb-kmod/metadata.xml9
-rw-r--r--x11-drivers/psb-kmod/psb-kmod-4.41.1_p8.ebuild62
3 files changed, 83 insertions, 0 deletions
diff --git a/x11-drivers/psb-kmod/ChangeLog b/x11-drivers/psb-kmod/ChangeLog
new file mode 100644
index 000000000000..0a58ede713b9
--- /dev/null
+++ b/x11-drivers/psb-kmod/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-drivers/psb-kmod
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/psb-kmod/ChangeLog,v 1.1 2009/09/13 20:10:43 patrick Exp $
+
+*psb-kmod-4.41.1_p8 (13 Sep 2009)
+
+ 13 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +psb-kmod-4.41.1_p8.ebuild, +metadata.xml:
+ Initial import of the intel poulsbo graphics driver and support libs.
+ Fixes #274184. Thanks to Konrad Campowsky for the ebuilds and all the
+ people who tested them.
+
diff --git a/x11-drivers/psb-kmod/metadata.xml b/x11-drivers/psb-kmod/metadata.xml
new file mode 100644
index 000000000000..e433c08d449a
--- /dev/null
+++ b/x11-drivers/psb-kmod/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-drivers/psb-kmod/psb-kmod-4.41.1_p8.ebuild b/x11-drivers/psb-kmod/psb-kmod-4.41.1_p8.ebuild
new file mode 100644
index 000000000000..244d61b27078
--- /dev/null
+++ b/x11-drivers/psb-kmod/psb-kmod-4.41.1_p8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/psb-kmod/psb-kmod-4.41.1_p8.ebuild,v 1.1 2009/09/13 20:10:43 patrick Exp $
+
+EAPI="2"
+
+inherit rpm linux-info linux-mod
+
+DESCRIPTION="kernel module for the intel gma500 (poulsbo)"
+HOMEPAGE="http://www.happyassassin.net/2009/05/13/native-poulsbo-gma-500-graphics-driver-for-fedora-10/"
+SRC_URI="http://adamwill.fedorapeople.org/poulsbo/src/psb-kmod-4.41.1-8.fc11.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-drivers/psb-firmware"
+RDEPEND=""
+
+S=${WORKDIR}/psb-kernel-source-4.41.1
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ local CONFIG_CHECK="FB_CFB_FILLRECT FB_CFB_COPYAREA FB_CFB_IMAGEBLIT ~FRAMEBUFFER_CONSOLE !DRM"
+ local ERROR_FB_CFB_FILLRECT="You don't have CONFIG_FB_CFB_FILLRECT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local ERROR_FB_CFB_COPYAREA="You don't have CONFIG_FB_CFB_FILLRECT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local ERROR_FB_CFB_IMAGEBLIT="You don't have CONFIG_FB_CFB_IMAGEBLIT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local WARNING_FBCON="You should really have CONFIG_FRAMEBUFFER_CONSOLE set in your kernel config. Otherwise you will get a seriously messed up console. You can work around this by loading the psb module with no_fb=1"
+
+ check_extra_config
+
+ linux_chkconfig_builtin "FRAMEBUFFER_CONSOLE" || ewarn "You really should not have CONFIG_FRAMEBUFFER_CONSOLE as a module. Otherwise you will get a seriously messed up console. You can work around this by loading the psb module with no_fb=1"
+}
+
+src_prepare()
+{
+ kernel_is gt 2 6 28 && epatch "${WORKDIR}/${PN}_build.patch"
+
+ if kernel_is gt 2 6 29; then
+ epatch "${WORKDIR}/${PN}-4.41.1_irqreturn.patch"
+ epatch "${WORKDIR}/${PN}-4.41.1_busid.patch"
+ fi
+}
+
+src_compile()
+{
+ # dirty hack :(
+ LINUXDIR=/usr/src/linux emake DRM_MODULES=psb || die
+}
+
+src_install()
+{
+ MODULE_NAMES="drm(kernel/drivers/gpu/drm:${S}:${S}) psb(kernel/drivers/gpu/drm:${S}:${S})"
+ MODULESD_PSB_ALIASES=(
+ "pci:v00008086d00008108sv*sd*bc*sc*i* psb"
+ "pci:v00008086d00008109sv*sd*bc*sc*i* psb"
+ )
+
+ linux-mod_src_install
+}