summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-04 21:30:49 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-04 21:30:49 +0000
commita016b58dd68173421b9518366310c2f4a721b423 (patch)
treee0d99fccf92e872b348f2f1352dfc7b43846bc51 /x11-drivers/xf86-input-mouse
parentmove sed to src_prepare (diff)
downloadgentoo-2-a016b58dd68173421b9518366310c2f4a721b423.tar.gz
gentoo-2-a016b58dd68173421b9518366310c2f4a721b423.tar.bz2
gentoo-2-a016b58dd68173421b9518366310c2f4a721b423.zip
Add patch to workaround gcc-4.6 bug. #435640
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-mouse')
-rw-r--r--x11-drivers/xf86-input-mouse/ChangeLog7
-rw-r--r--x11-drivers/xf86-input-mouse/files/xf86-input-mouse-1.8.1-gcc46-workaround.patch16
-rw-r--r--x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild7
3 files changed, 28 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-mouse/ChangeLog b/x11-drivers/xf86-input-mouse/ChangeLog
index b8cb44fca840..24558fbe48d3 100644
--- a/x11-drivers/xf86-input-mouse/ChangeLog
+++ b/x11-drivers/xf86-input-mouse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-input-mouse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/ChangeLog,v 1.124 2012/08/26 19:38:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/ChangeLog,v 1.125 2012/10/04 21:30:49 naota Exp $
+
+ 04 Oct 2012; <naota@gentoo.org>
+ +files/xf86-input-mouse-1.8.1-gcc46-workaround.patch,
+ xf86-input-mouse-1.8.1.ebuild:
+ Add patch to workaround gcc-4.6 bug. #435640
26 Aug 2012; Raúl Porcel <armin76@gentoo.org> xf86-input-mouse-1.7.2.ebuild:
alpha/ia64/sh/sparc stable wrt #419473
diff --git a/x11-drivers/xf86-input-mouse/files/xf86-input-mouse-1.8.1-gcc46-workaround.patch b/x11-drivers/xf86-input-mouse/files/xf86-input-mouse-1.8.1-gcc46-workaround.patch
new file mode 100644
index 000000000000..68670321ced1
--- /dev/null
+++ b/x11-drivers/xf86-input-mouse/files/xf86-input-mouse-1.8.1-gcc46-workaround.patch
@@ -0,0 +1,16 @@
+diff -Nur xf86-input-mouse-1.8.1.orig/src/bsd_mouse.c xf86-input-mouse-1.8.1/src/bsd_mouse.c
+--- xf86-input-mouse-1.8.1.orig/src/bsd_mouse.c 2012-05-28 09:01:45.000000000 +0900
++++ xf86-input-mouse-1.8.1/src/bsd_mouse.c 2012-09-20 22:27:36.167583000 +0900
+@@ -139,10 +139,10 @@
+ {
+ int i;
+
+- for (i = 0; internalNames[i]; i++)
++ for (i = 0; i < (sizeof(internalNames) / sizeof(internalNames[0])) - 1; i++)
+ if (xf86NameCmp(protocol, internalNames[i]) == 0)
+ return TRUE;
+- for (i = 0; miscNames[i]; i++)
++ for (i = 0; i < (sizeof(miscNames) / sizeof (miscNames[0])) - 1; i++)
+ if (xf86NameCmp(protocol, miscNames[i]) == 0)
+ return TRUE;
+ return FALSE;
diff --git a/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild b/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild
index 14a41d8fb606..f4baf54c8d49 100644
--- a/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild
+++ b/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild,v 1.1 2012/08/09 19:45:37 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.1.ebuild,v 1.2 2012/10/04 21:30:49 naota Exp $
EAPI=4
inherit xorg-2
@@ -12,3 +12,8 @@ IUSE=""
RDEPEND=">=x11-base/xorg-server-1.7"
DEPEND="${RDEPEND}"
+
+# To workaround gcc-4.6 bug 435640
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc46-workaround.patch
+)