summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-08 00:54:03 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-08 00:54:03 +0000
commit9000f2397c7b8c44fcca9198680f9fd6d540af9c (patch)
tree3c2c38962eba3c337addaaba2c0e7fe3fab3eb01 /x11-drivers/xf86-video-ati
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-9000f2397c7b8c44fcca9198680f9fd6d540af9c.tar.gz
gentoo-2-9000f2397c7b8c44fcca9198680f9fd6d540af9c.tar.bz2
gentoo-2-9000f2397c7b8c44fcca9198680f9fd6d540af9c.zip
Add build fix for xorg-server-1.12.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-xorg-server-1.12.patch118
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild7
3 files changed, 130 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 334e5175f48e..1e801d03b2cb 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.162 2012/03/03 16:29:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.163 2012/03/08 00:54:03 chithanh Exp $
+
+ 08 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ xf86-video-ati-6.14.3.ebuild,
+ +files/xf86-video-ati-6.14.3-xorg-server-1.12.patch:
+ Add build fix for xorg-server-1.12.
03 Mar 2012; Brent Baude <ranger@gentoo.org> xf86-video-ati-6.14.3.ebuild:
Marking xf86-video-ati-6.14.3 ppc64 stable for bug 394393
diff --git a/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-xorg-server-1.12.patch b/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-xorg-server-1.12.patch
new file mode 100644
index 000000000000..43fa945f9aea
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-xorg-server-1.12.patch
@@ -0,0 +1,118 @@
+From c66ae235700f5efe64eb168327551b8f1d153c9c Mon Sep 17 00:00:00 2001
+From: Michel Dänzer <michel.daenzer@amd.com>
+Date: Mon, 13 Feb 2012 09:43:58 +0000
+Subject: Handle new xorg_list API.
+
+Fixes https://bugs.freedesktop.org/show_bug.cgi?id=45937
+
+Signed-off-by: Michel Dänzer <michel.daenzer@amd.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 29f129a..0083325 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -234,10 +234,18 @@ AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
+ [#include "xorg-server.h"])
+
+ AC_CHECK_HEADERS([list.h],
+- [], [],
++ [have_list_h="yes"], [have_list_h="no"],
+ [#include <X11/Xdefs.h>
+ #include "xorg-server.h"])
+
++if test "x$have_list_h" = xyes; then
++ AC_CHECK_DECL(xorg_list_init,
++ [AC_DEFINE(HAVE_XORG_LIST, 1, [Have xorg_list API])], [],
++ [#include <X11/Xdefs.h>
++ #include "xorg-server.h"
++ #include "list.h"])
++fi
++
+ CPPFLAGS="$SAVE_CPPFLAGS"
+
+ AM_CONDITIONAL(USE_EXA, test "x$USE_EXA" = xyes)
+diff --git a/src/radeon_dri2.c b/src/radeon_dri2.c
+index 835575f..cf905a1 100644
+--- a/src/radeon_dri2.c
++++ b/src/radeon_dri2.c
+@@ -40,6 +40,13 @@
+
+ #if HAVE_LIST_H
+ #include "list.h"
++#if !HAVE_XORG_LIST
++#define xorg_list list
++#define xorg_list_init list_init
++#define xorg_list_add list_add
++#define xorg_list_del list_del
++#define xorg_list_for_each_entry list_for_each_entry
++#endif
+ #endif
+
+ #ifdef RADEON_DRI2
+@@ -515,11 +522,11 @@ typedef struct _DRI2FrameEvent {
+
+ Bool valid;
+
+- struct list link;
++ struct xorg_list link;
+ } DRI2FrameEventRec, *DRI2FrameEventPtr;
+
+ typedef struct _DRI2ClientEvents {
+- struct list reference_list;
++ struct xorg_list reference_list;
+ } DRI2ClientEventsRec, *DRI2ClientEventsPtr;
+
+ #if HAS_DEVPRIVATEKEYREC
+@@ -538,7 +545,7 @@ DevPrivateKey DRI2ClientEventsPrivateKey = &DRI2ClientEventsPrivateKeyIndex;
+ dixLookupPrivate(&(pClient)->devPrivates, DRI2ClientEventsPrivateKey))
+
+ static int
+-ListAddDRI2ClientEvents(ClientPtr client, struct list *entry)
++ListAddDRI2ClientEvents(ClientPtr client, struct xorg_list *entry)
+ {
+ DRI2ClientEventsPtr pClientPriv;
+ pClientPriv = GetDRI2ClientEvents(client);
+@@ -547,12 +554,12 @@ ListAddDRI2ClientEvents(ClientPtr client, struct list *entry)
+ return BadAlloc;
+ }
+
+- list_add(entry, &pClientPriv->reference_list);
++ xorg_list_add(entry, &pClientPriv->reference_list);
+ return 0;
+ }
+
+ static void
+-ListDelDRI2ClientEvents(ClientPtr client, struct list *entry)
++ListDelDRI2ClientEvents(ClientPtr client, struct xorg_list *entry)
+ {
+ DRI2ClientEventsPtr pClientPriv;
+ pClientPriv = GetDRI2ClientEvents(client);
+@@ -560,7 +567,7 @@ ListDelDRI2ClientEvents(ClientPtr client, struct list *entry)
+ if (!pClientPriv) {
+ return;
+ }
+- list_del(entry);
++ xorg_list_del(entry);
+ }
+
+ static void
+@@ -574,7 +581,7 @@ radeon_dri2_client_state_changed(CallbackListPtr *ClientStateCallback, pointer d
+
+ switch (pClient->clientState) {
+ case ClientStateInitial:
+- list_init(&pClientEventsPriv->reference_list);
++ xorg_list_init(&pClientEventsPriv->reference_list);
+ break;
+ case ClientStateRunning:
+ break;
+@@ -582,7 +589,7 @@ radeon_dri2_client_state_changed(CallbackListPtr *ClientStateCallback, pointer d
+ case ClientStateRetained:
+ case ClientStateGone:
+ if (pClientEventsPriv) {
+- list_for_each_entry(ref, &pClientEventsPriv->reference_list, link) {
++ xorg_list_for_each_entry(ref, &pClientEventsPriv->reference_list, link) {
+ ref->valid = FALSE;
+ }
+ }
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild
index d0ed507c78a4..2d9d4874e17b 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild,v 1.6 2012/03/03 16:29:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3.ebuild,v 1.7 2012/03/08 00:54:03 chithanh Exp $
EAPI=4
+XORG_EAUTORECONF=yes
XORG_DRI=always
inherit xorg-2
@@ -15,6 +16,10 @@ IUSE=""
RDEPEND="x11-libs/libdrm[video_cards_radeon]"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.14.3-xorg-server-1.12.patch
+)
+
pkg_setup() {
xorg-2_pkg_setup
XORG_CONFIGURE_OPTIONS=(