summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 16:08:30 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 16:08:30 +0000
commitcf935d8bcf26f8471d1ae05f14c46acfb92e1550 (patch)
tree791cafc04cc7664b0ce8cb6812e2e9b63f03967d /x11-drivers/xf86-video-vesa
parentsparc stable wrt #393919 (diff)
downloadgentoo-2-cf935d8bcf26f8471d1ae05f14c46acfb92e1550.tar.gz
gentoo-2-cf935d8bcf26f8471d1ae05f14c46acfb92e1550.tar.bz2
gentoo-2-cf935d8bcf26f8471d1ae05f14c46acfb92e1550.zip
Fix building against xorg-server-1.12.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-vesa')
-rw-r--r--x11-drivers/xf86-video-vesa/ChangeLog12
-rw-r--r--x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-pci-domains.patch55
-rw-r--r--x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-xorg-server-1.12.patch30
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.0-r1.ebuild18
4 files changed, 113 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-vesa/ChangeLog b/x11-drivers/xf86-video-vesa/ChangeLog
index ea2a95396a3a..f1887aeb0dec 100644
--- a/x11-drivers/xf86-video-vesa/ChangeLog
+++ b/x11-drivers/xf86-video-vesa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-vesa
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vesa/ChangeLog,v 1.52 2011/02/13 19:08:04 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vesa/ChangeLog,v 1.53 2012/03/18 16:08:30 chithanh Exp $
+
+*xf86-video-vesa-2.3.0-r1 (18 Mar 2012)
+
+ 18 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-vesa-2.3.0-pci-domains.patch,
+ +files/xf86-video-vesa-2.3.0-xorg-server-1.12.patch,
+ +xf86-video-vesa-2.3.0-r1.ebuild:
+ Fix building against xorg-server-1.12.
13 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-xf86-video-vesa-2.2.1.ebuild:
diff --git a/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-pci-domains.patch b/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-pci-domains.patch
new file mode 100644
index 000000000000..645fbc160d6f
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-pci-domains.patch
@@ -0,0 +1,55 @@
+From 1f84310ddf49778f776a39810aa98211c812e8ab Mon Sep 17 00:00:00 2001
+From: Jeremy Huddleston <jeremyhu@apple.com>
+Date: Wed, 19 Oct 2011 08:33:07 +0000
+Subject: Build fix for ABI Version 12
+
+ABI Version 12 removes support for multiple PCI domains. If you need to
+use this driver on a system with more than one PCI domain, you should
+either port this driver to using libpciaccess directly or stick with an
+older server.
+
+Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
+---
+diff --git a/src/vesa.c b/src/vesa.c
+index 1136ac3..5a0120c 100644
+--- a/src/vesa.c
++++ b/src/vesa.c
+@@ -1268,14 +1268,16 @@ VESAMapVidMem(ScrnInfoPtr pScrn)
+ & pVesa->base);
+ }
+ else
+- pVesa->base = xf86MapDomainMemory(pScrn->scrnIndex, 0, pVesa->pciInfo,
+- pScrn->memPhysBase, pVesa->mapSize);
++ (void) pci_device_map_legacy(pVesa->pciInfo, pScrn->memPhysBase,
++ pVesa->mapSize,
++ PCI_DEV_MAP_FLAG_WRITABLE,
++ & pVesa->base);
+
+ if (pVesa->base) {
+ if (pVesa->mapPhys != 0xa0000)
+- pVesa->VGAbase = xf86MapDomainMemory(pScrn->scrnIndex, 0,
+- pVesa->pciInfo,
+- 0xa0000, 0x10000);
++ (void) pci_device_map_legacy(pVesa->pciInfo, 0xa0000, 0x10000,
++ PCI_DEV_MAP_FLAG_WRITABLE,
++ & pVesa->VGAbase);
+ else
+ pVesa->VGAbase = pVesa->base;
+
+@@ -1325,10 +1327,12 @@ VESAUnmapVidMem(ScrnInfoPtr pScrn)
+ if (pVesa->mapPhys != 0xa0000) {
+ (void) pci_device_unmap_range(pVesa->pciInfo, pVesa->base,
+ pVesa->mapSize);
+- xf86UnMapVidMem(pScrn->scrnIndex, pVesa->VGAbase, 0x10000);
++ (void) pci_device_unmap_legacy(pVesa->pciInfo, pVesa->VGAbase,
++ 0x10000);
+ }
+ else {
+- xf86UnMapVidMem(pScrn->scrnIndex, pVesa->base, pVesa->mapSize);
++ (void) pci_device_unmap_legacy(pVesa->pciInfo, pVesa->base,
++ pVesa->mapSize);
+ }
+ #else
+ xf86UnMapVidMem(pScrn->scrnIndex, pVesa->base, pVesa->mapSize);
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-xorg-server-1.12.patch b/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-xorg-server-1.12.patch
new file mode 100644
index 000000000000..697dc278ec9e
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/files/xf86-video-vesa-2.3.0-xorg-server-1.12.patch
@@ -0,0 +1,30 @@
+From 463886df688d3521afc47ec88f9aaf67e924ec7f Mon Sep 17 00:00:00 2001
+From: Jeremy Huddleston <jeremyhu@apple.com>
+Date: Wed, 19 Oct 2011 08:15:03 +0000
+Subject: Build fix for ABI Version 12
+
+ABI Version 12 removes support for multiple PCI domains. If you need to
+use this driver on a system with more than one PCI domain, you should
+either port this driver to using libpciaccess directly or stick with an
+older server.
+
+Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
+---
+diff --git a/src/vesa.c b/src/vesa.c
+index 61d3550..1136ac3 100644
+--- a/src/vesa.c
++++ b/src/vesa.c
+@@ -1299,7 +1299,11 @@ VESAMapVidMem(ScrnInfoPtr pScrn)
+ }
+ #endif
+
++#if GET_ABI_MAJOR(ABI_VIDEODRV_VERSION) < 12
+ pVesa->ioBase = pScrn->domainIOBase;
++#else
++ pVesa->ioBase = 0;
++#endif
+
+ xf86DrvMsgVerb(pScrn->scrnIndex, X_INFO, DEBUG_VERB,
+ "virtual address = %p,\n"
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.0-r1.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..91a6081bfd84
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.0-r1.ebuild,v 1.1 2012/03/18 16:08:30 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.0-xorg-server-1.12.patch
+ "${FILESDIR}"/${PN}-2.3.0-pci-domains.patch
+)