summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-01-06 14:44:01 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-01-06 14:44:01 +0000
commitea942bf30030f8eab9bc1baa43b3bcca3f9eddd0 (patch)
tree5cdcffdc753289bcc2a82c0b8f082aa4e2170e4d /x11-drivers
parentsci-libs/indilib: Punt base.eclass; install udev files in correct location (diff)
downloadgentoo-2-ea942bf30030f8eab9bc1baa43b3bcca3f9eddd0.tar.gz
gentoo-2-ea942bf30030f8eab9bc1baa43b3bcca3f9eddd0.tar.bz2
gentoo-2-ea942bf30030f8eab9bc1baa43b3bcca3f9eddd0.zip
Fix issues with window decoration corruption on ivy bridge.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-intel/ChangeLog9
-rw-r--r--x11-drivers/xf86-video-intel/files/xf86-video-intel-2.99.907-invalidation.patch46
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.99.907-r1.ebuild72
3 files changed, 126 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-intel/ChangeLog b/x11-drivers/xf86-video-intel/ChangeLog
index e57ca1248811..0f40dcb37f77 100644
--- a/x11-drivers/xf86-video-intel/ChangeLog
+++ b/x11-drivers/xf86-video-intel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-intel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/ChangeLog,v 1.152 2014/01/02 22:51:51 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/ChangeLog,v 1.153 2014/01/06 14:44:01 zx2c4 Exp $
+
+*xf86-video-intel-2.99.907-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +files/xf86-video-intel-2.99.907-invalidation.patch,
+ +xf86-video-intel-2.99.907-r1.ebuild:
+ Fix issues with window decoration corruption on ivy bridge.
*xf86-video-intel-2.99.907 (02 Jan 2014)
diff --git a/x11-drivers/xf86-video-intel/files/xf86-video-intel-2.99.907-invalidation.patch b/x11-drivers/xf86-video-intel/files/xf86-video-intel-2.99.907-invalidation.patch
new file mode 100644
index 000000000000..e78d5bf336b0
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/files/xf86-video-intel-2.99.907-invalidation.patch
@@ -0,0 +1,46 @@
+From 4d8f78bc95f8dd36693f74365dbc3c442fbbf8a9 Mon Sep 17 00:00:00 2001
+From: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Thu, 02 Jan 2014 15:01:38 +0000
+Subject: sna/gen7+: Emit invalidate between operations if rendering to source/mask
+
+Fixes regression from
+commit c79cb18407273dc7798618390bd0b7d69b0f80d6 [2.99.907]
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Wed Nov 20 11:17:20 2013 +0000
+
+ sna/gen7: Try to reduce flushes between primitive continuations
+
+Reported-by: Simon Munton <simon.j.munton@gmail.com>
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=73208
+Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+---
+diff --git a/src/sna/gen7_render.c b/src/sna/gen7_render.c
+index 572e3e3..e45555b 100644
+--- a/src/sna/gen7_render.c
++++ b/src/sna/gen7_render.c
+@@ -1114,8 +1114,7 @@ gen7_emit_state(struct sna *sna,
+
+ need_stall = sna->render_state.gen7.surface_table != wm_binding_table;
+
+- need_invalidate = need_stall &&
+- (kgem_bo_is_dirty(op->src.bo) || kgem_bo_is_dirty(op->mask.bo));
++ need_invalidate = kgem_bo_is_dirty(op->src.bo) || kgem_bo_is_dirty(op->mask.bo);
+ if (ALWAYS_INVALIDATE)
+ need_invalidate = true;
+
+diff --git a/src/sna/gen8_render.c b/src/sna/gen8_render.c
+index a8b4ea8..309398d 100644
+--- a/src/sna/gen8_render.c
++++ b/src/sna/gen8_render.c
+@@ -1130,8 +1130,7 @@ gen8_emit_state(struct sna *sna,
+
+ need_stall = sna->render_state.gen8.surface_table != wm_binding_table;
+
+- need_invalidate = need_stall &&
+- (kgem_bo_is_dirty(op->src.bo) || kgem_bo_is_dirty(op->mask.bo));
++ need_invalidate = kgem_bo_is_dirty(op->src.bo) || kgem_bo_is_dirty(op->mask.bo);
+ if (ALWAYS_INVALIDATE)
+ need_invalidate = true;
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.907-r1.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.907-r1.ebuild
new file mode 100644
index 000000000000..dbc01261e72a
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.907-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.907-r1.ebuild,v 1.1 2014/01/06 14:44:01 zx2c4 Exp $
+
+EAPI=5
+
+XORG_DRI=dri
+inherit linux-info xorg-2
+
+DESCRIPTION="X.Org driver for Intel cards"
+
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd -x86-fbsd"
+IUSE="glamor +sna +udev uxa xvmc"
+
+REQUIRED_USE="
+ || ( sna uxa )
+ glamor? ( uxa )
+"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/pixman-0.27.1
+ >=x11-libs/libdrm-2.4.29[video_cards_intel]
+ glamor? (
+ x11-libs/glamor
+ )
+ sna? (
+ >=x11-base/xorg-server-1.10
+ )
+ udev? (
+ virtual/udev
+ )
+ xvmc? (
+ x11-libs/libXvMC
+ >=x11-libs/libxcb-1.5
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${RDEPEND}
+ >=x11-proto/dri2proto-2.6
+ x11-proto/resourceproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-invalidation.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ $(use_enable glamor)
+ $(use_enable sna)
+ $(use_enable uxa)
+ $(use_enable udev)
+ $(use_enable xvmc)
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ if linux_config_exists \
+ && ! linux_chkconfig_present DRM_I915_KMS; then
+ echo
+ ewarn "This driver requires KMS support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Graphics support --->"
+ ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
+ ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
+ ewarn " i915 driver"
+ ewarn " [*] Enable modesetting on intel by default"
+ echo
+ fi
+}