summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-14 20:01:53 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-14 20:01:53 +0000
commite9ac4def41f57ffdb1ab770aea4d8a287a56b75e (patch)
tree45e05ddf3ed13828ad76a0c1e1a09e0c20b2fb00 /x11-libs/cairo/cairo-9999.ebuild
parentQA: Define mandatory ebuild variables, bug 425848. (diff)
downloadgentoo-2-e9ac4def41f57ffdb1ab770aea4d8a287a56b75e.tar.gz
gentoo-2-e9ac4def41f57ffdb1ab770aea4d8a287a56b75e.tar.bz2
gentoo-2-e9ac4def41f57ffdb1ab770aea4d8a287a56b75e.zip
Clean up Live ebuild handling. Sync latest release version ebuild with the Live ebuild.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/cairo/cairo-9999.ebuild')
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 950ec3646e49..697f2c0d95e4 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,21 +1,25 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.19 2012/05/05 03:52:25 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.20 2012/07/14 20:01:53 cardoe Exp $
EAPI=4
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
-[[ ${PV} == *9999 ]] && GIT_ECLASS="git-2"
+inherit eutils flag-o-matic autotools
-inherit eutils flag-o-matic autotools ${GIT_ECLASS}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="http://cairographics.org/"
-[[ ${PV} == *9999 ]] || SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
-
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="X aqua debug directfb doc drm gallium +glib opengl openvg qt4 static-libs +svg xcb"
# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
@@ -98,6 +102,8 @@ src_configure() {
use X && myopts+=" --enable-tee=yes"
+ use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
+
# --disable-xcb-lib:
# do not override good xlib backed by hardforcing rendering over xcb
econf \