summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-24 13:08:01 +0000
committerBen de Groot <yngwin@gentoo.org>2012-07-24 13:08:01 +0000
commit6852a1a0297378c02c72328097125099bac1263e (patch)
tree4a1fb6fd81ec01e5e716de0be1cb469a7dbc638c /x11-libs/cairo
parentInitial commit (diff)
downloadgentoo-2-6852a1a0297378c02c72328097125099bac1263e.tar.gz
gentoo-2-6852a1a0297378c02c72328097125099bac1263e.tar.bz2
gentoo-2-6852a1a0297378c02c72328097125099bac1263e.zip
Take over maintainership, since spatz is being retired. Add back qt-surface.patch to 1.12.2 (bug #418133). Add respect-fontconfig patch by Paul Bradbury (https://bugs.freedesktop.org/show_bug.cgi?id=11838#c8).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog10
-rw-r--r--x11-libs/cairo/cairo-1.12.2-r1.ebuild144
-rw-r--r--x11-libs/cairo/files/cairo-respect-fontconfig.patch13
-rw-r--r--x11-libs/cairo/metadata.xml37
4 files changed, 184 insertions, 20 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 7bda82714b7f..dd0216dd9a8e 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.298 2012/07/14 20:01:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.299 2012/07/24 13:08:01 yngwin Exp $
+
+*cairo-1.12.2-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Ben de Groot <yngwin@gentoo.org> +cairo-1.12.2-r1.ebuild,
+ +files/cairo-respect-fontconfig.patch, metadata.xml:
+ Take over maintainership, since spatz is being retired. Add back qt-
+ surface.patch to 1.12.2 (bug #418133). Add respect-fontconfig patch by Paul
+ Bradbury (https://bugs.freedesktop.org/show_bug.cgi?id=11838#c8).
14 Jul 2012; Doug Goldstein <cardoe@gentoo.org> cairo-1.12.2.ebuild,
cairo-9999.ebuild:
diff --git a/x11-libs/cairo/cairo-1.12.2-r1.ebuild b/x11-libs/cairo/cairo-1.12.2-r1.ebuild
new file mode 100644
index 000000000000..041ce27ba732
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.12.2-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.12.2-r1.ebuild,v 1.1 2012/07/24 13:08:01 yngwin Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic autotools
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="X aqua debug directfb doc drm gallium +glib opengl openvg qt4 static-libs +svg xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libpng:0
+ sys-libs/zlib
+ >=x11-libs/pixman-0.18.4
+ directfb? ( dev-libs/DirectFB )
+ glib? ( >=dev-libs/glib-2.28.6:2 )
+ opengl? ( virtual/opengl )
+ openvg? ( media-libs/mesa[openvg] )
+ qt4? ( >=x11-libs/qt-gui-4.8:4 )
+ svg? ( dev-libs/libxml2 )
+ X? (
+ >=x11-libs/libXrender-0.6
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXft
+ drm? (
+ >=sys-fs/udev-136
+ gallium? ( media-libs/mesa[gallium] )
+ )
+ )
+ xcb? (
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-2
+ doc? (
+ >=dev-util/gtk-doc-1.6
+ ~app-text/docbook-xml-dtd-4.2
+ )
+ X? (
+ x11-proto/renderproto
+ drm? (
+ x11-proto/xproto
+ >=x11-proto/xextproto-7.1
+ )
+ )"
+
+# drm module requires X
+# for gallium we need to enable drm
+REQUIRED_USE="
+ drm? ( X )
+ gallium? ( drm )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
+ epatch "${FILESDIR}"/${PN}-1.10.2-qt-surface.patch
+ epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
+
+ # Slightly messed build system YAY
+ if [[ ${PV} == *9999* ]]; then
+ touch boilerplate/Makefile.am.features
+ touch src/Makefile.am.features
+ touch ChangeLog
+ fi
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ # upgraded to an eautoreconf for the above interix patch.
+ eautoreconf
+}
+
+src_configure() {
+ local myopts
+
+ # SuperH doesn't have native atomics yet
+ use sh && myopts+=" --disable-atomic"
+
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
+ # http://bugs.freedesktop.org/show_bug.cgi?id=15463
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D_POSIX_PTHREAD_SEMANTICS
+
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ use X && myopts+=" --enable-tee=yes"
+
+ use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
+
+ # --disable-xcb-lib:
+ # do not override good xlib backed by hardforcing rendering over xcb
+ econf \
+ --disable-dependency-tracking \
+ $(use_with X x) \
+ $(use_enable X xlib) \
+ $(use_enable X xlib-xrender) \
+ $(use_enable aqua quartz) \
+ $(use_enable aqua quartz-image) \
+ $(use_enable debug test-surfaces) \
+ $(use_enable directfb) \
+ $(use_enable glib gobject) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openvg vg) \
+ $(use_enable opengl gl) \
+ $(use_enable qt4 qt) \
+ $(use_enable static-libs static) \
+ $(use_enable svg) \
+ $(use_enable xcb) \
+ $(use_enable xcb xcb-shm) \
+ $(use_enable drm) \
+ $(use_enable gallium) \
+ --enable-ft \
+ --enable-pdf \
+ --enable-png \
+ --enable-ps \
+ --disable-xlib-xcb \
+ ${myopts}
+}
+
+src_install() {
+ # parallel make install fails
+ emake -j1 DESTDIR="${D}" install
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/x11-libs/cairo/files/cairo-respect-fontconfig.patch b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
new file mode 100644
index 000000000000..b0a1b2963502
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
@@ -0,0 +1,13 @@
+--- cairo-1.7.6-orig/src/cairo-ft-font.c 2008-09-29 21:43:13.000000000 +0100
++++ cairo-1.7.6/src/cairo-ft-font.c 2008-09-29 21:52:19.000000000 +0100
+@@ -1705,7 +1705,9 @@
+ options->base.subpixel_order = other->base.subpixel_order;
+ }
+
+- if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
++ options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
++
++ if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
+ options->base.hint_style = other->base.hint_style;
+
+ if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)
diff --git a/x11-libs/cairo/metadata.xml b/x11-libs/cairo/metadata.xml
index c9d8a0b57837..9253bd379cc8 100644
--- a/x11-libs/cairo/metadata.xml
+++ b/x11-libs/cairo/metadata.xml
@@ -1,23 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>x11</herd>
-<maintainer>
- <email>spatz@gentoo.org</email>
- <name>Dror Levin</name>
-</maintainer>
-<use>
- <flag name='cleartype'>Add ClearType-style behavior for sub-pixel hinting.
- Patch taken from Arch Linux</flag>
- <flag name='lcdfilter'>Add FreeType LCD filtering, ClearType-style behavior
- for sub-pixel-hinting. Overrides cleartype USE flag. Patch taken from
- Ubuntu</flag>
- <flag name='opengl' restrict="&gt;=x11-libs/cairo-1.10.0">
- Use Mesa backend for acceleration
- </flag>
- <flag name='drm'>Use Linux DRM for backend acceleration</flag>
- <flag name='gallium'>Use Mesa's Gallium backend for acceleration</flag>
- <flag name='glib'>Compile with GLib Object System support</flag>
- <flag name='openvg'>Use OpenVG for backend acceleration</flag>
-</use>
+ <herd>x11</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+ <use>
+ <flag name='cleartype'>Add ClearType-style behavior for sub-pixel hinting.
+ Patch taken from Arch Linux</flag>
+ <flag name='lcdfilter'>Add FreeType LCD filtering, ClearType-style behavior
+ for sub-pixel-hinting. Overrides cleartype USE flag. Patch taken from
+ Ubuntu</flag>
+ <flag name='opengl' restrict="&gt;=x11-libs/cairo-1.10.0">
+ Use Mesa backend for acceleration</flag>
+ <flag name='drm'>Use Linux DRM for backend acceleration</flag>
+ <flag name='gallium'>Use Mesa's Gallium backend for acceleration</flag>
+ <flag name='glib'>Compile with GLib Object System support</flag>
+ <flag name='openvg'>Use OpenVG for backend acceleration</flag>
+ </use>
</pkgmetadata>