summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-08-09 07:06:42 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-08-09 07:06:42 +0000
commit9963e6ac1266c84272cee61609a800c866994607 (patch)
tree9ab70f88e0eaeec0ae850b6d33710dd6bb2b14bc /x11-libs/cairo
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-9963e6ac1266c84272cee61609a800c866994607.tar.gz
gentoo-2-9963e6ac1266c84272cee61609a800c866994607.tar.bz2
gentoo-2-9963e6ac1266c84272cee61609a800c866994607.zip
version bump from upstream
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.2.2.ebuild66
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.2.23
3 files changed, 75 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 759be6ecae07..1b899a72c7a3 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.78 2006/08/04 02:35:11 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.79 2006/08/09 07:06:42 compnerd Exp $
+
+*cairo-1.2.2 (09 Aug 2006)
+
+ 09 Aug 2006; Saleem Abdulrasool <compnerd@gentoo.org> +cairo-1.2.2.ebuild:
+ version bump from upstream
*cairo-1.2.0-r1 (04 Aug 2006)
diff --git a/x11-libs/cairo/cairo-1.2.2.ebuild b/x11-libs/cairo/cairo-1.2.2.ebuild
new file mode 100644
index 000000000000..332b43b9f1b0
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.2.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.2.ebuild,v 1.1 2006/08/09 07:06:42 compnerd Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb doc glitz pdf png svg X"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ X? (
+ || (
+ (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ )
+ virtual/x11
+ )
+ virtual/xft
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ png? ( media-libs/libpng )
+ svg? ( dev-libs/libxml2 )
+ !<x11-libs/cairo-0.2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ X? ( || ( x11-proto/renderproto virtual/x11 ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable png) $(use_enable svg) $(use_enable pdf) \
+ $(use_enable glitz) --enable-freetype --enable-ps \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "You will most likely need to run revdep-rebuild after emerging this"
+ echo
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.2.2 b/x11-libs/cairo/files/digest-cairo-1.2.2
new file mode 100644
index 000000000000..acfb35de78db
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.2.2
@@ -0,0 +1,3 @@
+MD5 2460487b1257a5583c889b1b9d2033ec cairo-1.2.2.tar.gz 2831305
+RMD160 ecb23495efb809b1a7e0af036ad3a260d68be9d5 cairo-1.2.2.tar.gz 2831305
+SHA256 9d53b8dd0bf76dd0da7cdbe65a6c6934be49bd3942dc5f7ef7bbcc7529d9ee02 cairo-1.2.2.tar.gz 2831305