summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-25 21:53:34 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-25 21:53:34 +0000
commit54423539b08937981ccaa51d21fc94468b3aa559 (patch)
tree2b67f27ffdebaff13aacd11f794309f8510d3074 /x11-libs/evas
parentNew and improved TCSH scripts. (diff)
downloadgentoo-2-54423539b08937981ccaa51d21fc94468b3aa559.tar.gz
gentoo-2-54423539b08937981ccaa51d21fc94468b3aa559.tar.bz2
gentoo-2-54423539b08937981ccaa51d21fc94468b3aa559.zip
touchups
Diffstat (limited to 'x11-libs/evas')
-rw-r--r--x11-libs/evas/ChangeLog6
-rw-r--r--x11-libs/evas/evas-0.6.0.ebuild34
2 files changed, 12 insertions, 28 deletions
diff --git a/x11-libs/evas/ChangeLog b/x11-libs/evas/ChangeLog
index 89dd419d4a46..9a1d10ef91c9 100644
--- a/x11-libs/evas/ChangeLog
+++ b/x11-libs/evas/ChangeLog
@@ -1,15 +1,11 @@
# ChangeLog for x11-libs/evas
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.3 2002/12/13 11:00:51 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.4 2003/01/25 21:53:34 vapier Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*evas-0.6.0 (20 Apr 2002)
20 Apr 2002; Leigh Dyer <lsd@linuxgamers.net> evas-0.6.0.ebuild:
-
Initial add to portage. Be sure to try evas_test once you've merged it.
-
Evas is a hardware-accelerated canvas API for X-Windows that can draw
anti-aliased text, smooth super and sub-sampled images, alpha-blend, as well
as drop down to using normal X11 primitives such as pixmaps, lines and
diff --git a/x11-libs/evas/evas-0.6.0.ebuild b/x11-libs/evas/evas-0.6.0.ebuild
index ee223995dc78..ddb12e5a4b0b 100644
--- a/x11-libs/evas/evas-0.6.0.ebuild
+++ b/x11-libs/evas/evas-0.6.0.ebuild
@@ -1,39 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-0.6.0.ebuild,v 1.9 2002/12/09 04:41:42 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-0.6.0.ebuild,v 1.10 2003/01/25 21:53:34 vapier Exp $
-IUSE="opengl"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="OpenGL-accelerated canvas library from the enlightenment project"
+DESCRIPTION="hardware-accelerated canvas library from the enlightenment project"
SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.bz2"
-HOMEPAGE="http://www.enlightenment.org"
+HOMEPAGE="http://www.enlightenment.org/"
+
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
+IUSE="opengl"
DEPEND="x11-base/xfree
- =media-libs/freetype-1*
- media-libs/imlib2
- opengl? ( virtual/opengl )"
+ =media-libs/freetype-1*
+ media-libs/imlib2
+ opengl? ( virtual/opengl )"
src_compile() {
- local myconf=""
-
- use opengl || myconf="${myconf} --disable-gl"
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
+ econf `use_enable opengl gl` || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING README FAQ-EVAS doc/evas.pdf
}