summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-16 13:21:27 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-16 13:21:27 +0000
commit32a661c5c0b059fb92838b9ad02e0c583b73ce9b (patch)
treec2c3e0ae8ad9061011bb5cad80239922f2dd0a08 /x11-libs/fltk
parentClean up src_configure: use proper arrays to hold flags, and use $ARCH rather... (diff)
downloadgentoo-2-32a661c5c0b059fb92838b9ad02e0c583b73ce9b.tar.gz
gentoo-2-32a661c5c0b059fb92838b9ad02e0c583b73ce9b.tar.bz2
gentoo-2-32a661c5c0b059fb92838b9ad02e0c583b73ce9b.zip
Convert sed script to patch. Make xutf8 functions visible (bug #536842 by Toralf Förster).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog10
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch14
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch165
-rw-r--r--x11-libs/fltk/fltk-1.3.3-r3.ebuild (renamed from x11-libs/fltk/fltk-1.3.3-r2.ebuild)10
4 files changed, 192 insertions, 7 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 27a1576e1258..5b1865ac1ca5 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.247 2015/01/19 12:01:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.248 2015/02/16 13:21:27 jer Exp $
+
+*fltk-1.3.3-r3 (16 Feb 2015)
+
+ 16 Feb 2015; Jeroen Roovers <jer@gentoo.org> -fltk-1.3.3-r2.ebuild,
+ +fltk-1.3.3-r3.ebuild, +files/fltk-1.3.3-fltk-config.patch,
+ +files/fltk-1.3.3-xutf8-visibility.patch:
+ Convert sed script to patch. Make xutf8 functions visible (bug #536842 by
+ Toralf Förster).
*fltk-1.3.9999 (19 Jan 2015)
diff --git a/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch b/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch
new file mode 100644
index 000000000000..ca7607afa4fc
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch
@@ -0,0 +1,14 @@
+--- a/fltk-config.in
++++ b/fltk-config.in
+@@ -42,9 +42,8 @@
+
+ # flags for C++ compiler:
+ ARCHFLAGS="@ARCHFLAGS@"
+-CFLAGS="@CFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+-CXXFLAGS="@CXXFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+-LDFLAGS="@LDFLAGS@"
++CFLAGS=" @LARGEFILE@ @PTHREAD_FLAGS@"
++CXXFLAGS=" @LARGEFILE@ @PTHREAD_FLAGS@"
+ LDLIBS="@LIBS@"
+ OPTIM="@OPTIM@"
+ CAIROFLAGS="@CAIROFLAGS@"
diff --git a/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch b/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch
new file mode 100644
index 000000000000..f30105e18c06
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch
@@ -0,0 +1,165 @@
+--- a/src/xutf8/utf8Input.c
++++ b/src/xutf8/utf8Input.c
+@@ -18,6 +18,7 @@
+
+ #include <config.h>
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+@@ -53,7 +54,7 @@ typedef struct {
+ #include "lcUniConv/jisx0212.h"
+ #include "lcUniConv/ksc5601.h"
+
+-static int
++FL_EXPORT static int
+ XConvertEucTwToUtf8(char* buffer_return, int len) {
+ /* FIXME */
+ #if HAVE_LIBC_ICONV
+@@ -120,7 +121,7 @@ XConvertEucTwToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucKrToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -160,7 +161,7 @@ XConvertEucKrToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertBig5ToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -189,7 +190,7 @@ XConvertBig5ToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertCp936extToUtf8(char* buffer_return, int len)
+ {
+ int i = 0, l = 0;
+@@ -226,7 +227,7 @@ XConvertCp936extToUtf8(char* buffer_retu
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertGb2312ToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -261,7 +262,7 @@ XConvertGb2312ToUtf8(char* buffer_return
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucCnToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -300,7 +301,7 @@ XConvertEucCnToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucJpToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -373,7 +374,7 @@ XConvertEucJpToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucToUtf8(const char* locale,
+ char* buffer_return,
+ int len,
+@@ -408,7 +409,7 @@ XConvertEucToUtf8(const char* locale,
+ return len;
+ }
+
+-int
++FL_EXPORT int
+ XUtf8LookupString(XIC ic,
+ XKeyPressedEvent* event,
+ char* buffer_return,
+--- a/src/xutf8/utf8Utils.c
++++ b/src/xutf8/utf8Utils.c
+@@ -21,6 +21,7 @@
+ #if !defined(WIN32) && !defined(__APPLE__)
+
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+
+ /*** NOTE : all functions are LIMITED to 24 bits Unicode values !!! ***/
+
+@@ -29,7 +30,7 @@
+ * Returns the byte length of the converted UTF-8 char
+ * Returns -1 if the UTF-8 string is not valid
+ */
+-int
++FL_EXPORT int
+ XConvertUtf8ToUcs(const unsigned char *buf,
+ int len,
+ unsigned int *ucs) {
+@@ -137,7 +138,7 @@ XConvertUcsToUtf8(unsigned int ucs,
+ * returns the byte length of the first UTF-8 char
+ * (returns -1 if not valid)
+ */
+-int
++FL_EXPORT int
+ XUtf8CharByteLen(const unsigned char *buf,
+ int len) {
+ unsigned int ucs;
+@@ -165,7 +166,7 @@ XCountUtf8Char(const unsigned char *buf
+ /*
+ * Same as XConvertUtf8ToUcs but no sanity check is done.
+ */
+-int
++FL_EXPORT int
+ XFastConvertUtf8ToUcs(const unsigned char *buf,
+ int len,
+ unsigned int *ucs) {
+--- a/src/xutf8/utf8Wrap.c
++++ b/src/xutf8/utf8Wrap.c
+@@ -20,6 +20,7 @@
+ #if !defined(WIN32) && !defined(__APPLE__)
+
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+ #include <X11/Xlib.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+@@ -705,7 +706,7 @@ XUtf8_measure_extents(
+ /*****************************************************************************/
+ /** returns the pixel width of a UTF-8 string **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XUtf8TextWidth(XUtf8FontStruct *font_set,
+ const char *string,
+ int num_bytes) {
+@@ -815,7 +816,7 @@ XUtf8TextWidth(XUtf8FontStruct *font_se
+ /*****************************************************************************/
+ /** get the X font and glyph ID of a UCS char **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XGetUtf8FontAndGlyph(XUtf8FontStruct *font_set,
+ unsigned int ucs,
+ XFontStruct **fnt,
+@@ -886,7 +887,7 @@ XGetUtf8FontAndGlyph(XUtf8FontStruct *f
+ /*****************************************************************************/
+ /** returns the pixel width of a UCS char **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XUtf8UcsWidth(XUtf8FontStruct *font_set,
+ unsigned int ucs) {
+
diff --git a/x11-libs/fltk/fltk-1.3.3-r2.ebuild b/x11-libs/fltk/fltk-1.3.3-r3.ebuild
index 296936a92c26..3ae5168f0f14 100644
--- a/x11-libs/fltk/fltk-1.3.3-r2.ebuild
+++ b/x11-libs/fltk/fltk-1.3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.3-r2.ebuild,v 1.2 2015/01/14 09:21:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.3-r3.ebuild,v 1.1 2015/02/16 13:21:27 jer Exp $
EAPI=5
@@ -50,14 +50,12 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.3.2-conf-tests.patch \
"${FILESDIR}"/${PN}-1.3.2-jpeg-9a.patch \
"${FILESDIR}"/${PN}-1.3.3-visibility.patch \
- "${FILESDIR}"/${PN}-1.3.3-fl_open_display.patch
+ "${FILESDIR}"/${PN}-1.3.3-fl_open_display.patch \
+ "${FILESDIR}"/${PN}-1.3.3-fltk-config.patch \
+ "${FILESDIR}"/${PN}-1.3.3-xutf8-visibility.patch
sed -i \
-e 's:@HLINKS@::g' FL/Makefile.in || die
- sed -i \
- -e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
- -e '/^LDFLAGS=/d' \
- "${S}/fltk-config.in" || die
# some fixes introduced because slotting
sed -i \
-e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \