summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-19 14:06:54 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-19 14:06:54 +0000
commitdd495ea89a12068440b1dd50799c4f63f9186610 (patch)
treea31f63935945c8a9fad876aa6f0c3b70478ef000 /x11-libs/fltk
parentFix build with -Werror=format-security, bug #520984 (diff)
downloadgentoo-2-dd495ea89a12068440b1dd50799c4f63f9186610.tar.gz
gentoo-2-dd495ea89a12068440b1dd50799c4f63f9186610.tar.bz2
gentoo-2-dd495ea89a12068440b1dd50799c4f63f9186610.zip
Fix segmentation fault in vncview (net-misc/tigervnc) (bug #529856 by Maxim Britov).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog9
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch10
-rw-r--r--x11-libs/fltk/fltk-1.3.3-r1.ebuild170
3 files changed, 188 insertions, 1 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 06cce36021cc..d959cdcb2b3f 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.242 2014/11/08 18:17:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.243 2014/11/19 14:06:54 jer Exp $
+
+*fltk-1.3.3-r1 (19 Nov 2014)
+
+ 19 Nov 2014; Jeroen Roovers <jer@gentoo.org> +fltk-1.3.3-r1.ebuild,
+ +files/fltk-1.3.3-fl_open_display.patch:
+ Fix segmentation fault in vncview (net-misc/tigervnc) (bug #529856 by Maxim
+ Britov).
08 Nov 2014; Jeroen Roovers <jer@gentoo.org> fltk-1.3.3.ebuild:
Readd the old USE=static-libs after a fruitless venture into redesigning the
diff --git a/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch b/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch
new file mode 100644
index 000000000000..562f1157038f
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch
@@ -0,0 +1,10 @@
+--- a/src/Fl_x.cxx
++++ b/src/Fl_x.cxx
+@@ -2211,6 +2211,7 @@
+ static int result = -1;
+
+ if (result == -1) {
++ fl_open_display();
+ result = 0;
+ unsigned long nitems;
+ unsigned long *words = 0;
diff --git a/x11-libs/fltk/fltk-1.3.3-r1.ebuild b/x11-libs/fltk/fltk-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..888218b09254
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.3.3-r1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.3-r1.ebuild,v 1.1 2014/11/19 14:06:54 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils fdo-mime flag-o-matic
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL"
+HOMEPAGE="http://www.fltk.org/"
+SRC_URI="http://fltk.org/pub/${PN}/${PV}/${P}-source.tar.gz"
+
+SLOT="1"
+LICENSE="FLTK LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="cairo debug doc examples games opengl pdf static-libs threads xft xinerama"
+
+RDEPEND="
+ >=media-libs/libpng-1.2:0
+ virtual/jpeg:0
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXt
+ cairo? ( x11-libs/cairo )
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ doc? (
+ app-doc/doxygen
+ pdf? ( dev-texlive/texlive-latex )
+ )
+ xinerama? ( x11-proto/xineramaproto )"
+
+FLTK_INCDIR=${EPREFIX}/usr/include/fltk
+FLTK_LIBDIR=${EPREFIX}/usr/$(get_libdir)/fltk
+
+src_prepare() {
+ rm -rf zlib jpeg png || die
+ epatch \
+ "${FILESDIR}"/${PN}-1.3.2-desktop.patch \
+ "${FILESDIR}"/${PN}-1.3.0-share.patch \
+ "${FILESDIR}"/${PN}-1.3.2-conf-tests.patch \
+ "${FILESDIR}"/${PN}-1.3.2-jpeg-9a.patch \
+ "${FILESDIR}"/${PN}-1.3.3-visibility.patch \
+ "${FILESDIR}"/${PN}-1.3.3-fl_open_display.patch
+
+ sed -i \
+ -e 's:@HLINKS@::g' FL/Makefile.in || die
+ sed -i \
+ -e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
+ -e '/^LDFLAGS=/d' \
+ "${S}/fltk-config.in" || die
+ # some fixes introduced because slotting
+ sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || die
+ # docs in proper docdir
+ sed -i \
+ -e "/^docdir/s:fltk:${PF}/html:" \
+ -e "/SILENT:/d" \
+ makeinclude.in || die
+ sed -e "s/7/${PV}/" \
+ < "${FILESDIR}"/FLTKConfig.cmake \
+ > CMake/FLTKConfig.cmake || die
+ sed -e 's:-Os::g' -i configure.in || die
+
+ use prefix && append-ldflags -Wl,-rpath -Wl,"${FLTK_LIBDIR}"
+
+ # also in Makefile:config.guess config.sub:
+ cp misc/config.{guess,sub} . || die
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --includedir=${FLTK_INCDIR}\
+ --libdir=${FLTK_LIBDIR} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --enable-largefile \
+ --enable-shared \
+ --enable-xdbe \
+ --disable-localjpeg \
+ --disable-localpng \
+ --disable-localzlib \
+ $(use_enable debug) \
+ $(use_enable cairo) \
+ $(use_enable opengl gl) \
+ $(use_enable threads) \
+ $(use_enable xft) \
+ $(use_enable xinerama)
+}
+
+src_compile() {
+ default
+ if use doc; then
+ cd "${S}"/documentation
+ emake html
+ if use pdf; then
+ emake pdf
+ fi
+ fi
+ if use games; then
+ cd "${S}"/test
+ emake blocks checkers sudoku
+ fi
+}
+
+src_test() {
+ emake -C test
+}
+
+src_install() {
+ default
+
+ emake -C fluid \
+ DESTDIR="${D}" install-linux
+ if use doc; then
+ emake -C documentation \
+ DESTDIR="${D}" install
+ fi
+
+ local apps="fluid"
+ if use games; then
+ emake -C test \
+ DESTDIR="${D}" install-linux
+ emake -C documentation \
+ DESTDIR="${D}" install-linux
+ apps+=" sudoku blocks checkers"
+ fi
+
+ for app in ${apps}; do
+ dosym /usr/share/icons/hicolor/32x32/apps/${app}.png \
+ /usr/share/pixmaps/${app}.png
+ done
+
+ dodoc CHANGES README CREDITS ANNOUNCEMENT
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{h,cxx,fl} test/demo.menu
+ fi
+
+ insinto /usr/share/cmake/Modules
+ doins CMake/FLTK*.cmake
+
+ echo "LDPATH=${FLTK_LIBDIR}" > 99fltk
+ echo "FLTK_DOCDIR=${EPREFIX}/usr/share/doc/${PF}/html" >> 99fltk
+ doenvd 99fltk
+
+ # FIXME: This is bad, but building only shared libraries is hardly supported
+ # FIXME: The executables in test/ are linking statically against libfltk
+ if ! use static-libs; then
+ rm "${ED}"/usr/lib*/fltk/*.a || die
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}