summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-03-01 22:58:16 +0000
committerMatti Bickel <mabi@gentoo.org>2009-03-01 22:58:16 +0000
commit55812e195ced50e1c13848bb4a3451d600243a7d (patch)
tree70e59af5851ed1da9dd0f3b093534c6aaa20248d /x11-libs/fox-wrapper
parentFix a typo in a patch filename. (diff)
downloadgentoo-2-55812e195ced50e1c13848bb4a3451d600243a7d.tar.gz
gentoo-2-55812e195ced50e1c13848bb4a3451d600243a7d.tar.bz2
gentoo-2-55812e195ced50e1c13848bb4a3451d600243a7d.zip
1.7 support, dropped 1.2,1.5
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'x11-libs/fox-wrapper')
-rw-r--r--x11-libs/fox-wrapper/ChangeLog10
-rw-r--r--x11-libs/fox-wrapper/files/fox-wrapper-3.sh76
-rw-r--r--x11-libs/fox-wrapper/fox-wrapper-3.ebuild24
3 files changed, 108 insertions, 2 deletions
diff --git a/x11-libs/fox-wrapper/ChangeLog b/x11-libs/fox-wrapper/ChangeLog
index c643a5703782..0a5d888f77d4 100644
--- a/x11-libs/fox-wrapper/ChangeLog
+++ b/x11-libs/fox-wrapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/fox-wrapper
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox-wrapper/ChangeLog,v 1.16 2007/04/09 22:43:03 kloeri Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox-wrapper/ChangeLog,v 1.17 2009/03/01 22:58:16 mabi Exp $
+
+*fox-wrapper-3 (01 Mar 2009)
+
+ 01 Mar 2009; Matti Bickel <mabi@gentoo.org> +files/fox-wrapper-3.sh,
+ +fox-wrapper-3.ebuild:
+ add a new wrapper for 1.7, loose 1.2 support
09 Apr 2007; Bryan Østergaard <kloeri@gentoo.org> fox-wrapper-2.ebuild:
Stable on Alpha, bug 164296.
diff --git a/x11-libs/fox-wrapper/files/fox-wrapper-3.sh b/x11-libs/fox-wrapper/files/fox-wrapper-3.sh
new file mode 100644
index 000000000000..45561d6e4597
--- /dev/null
+++ b/x11-libs/fox-wrapper/files/fox-wrapper-3.sh
@@ -0,0 +1,76 @@
+#!/bin/bash
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox-wrapper/files/fox-wrapper-3.sh,v 1.1 2009/03/01 22:58:16 mabi Exp $
+
+# Based on the am-wrapper.sh script (sys-devel/automake-wrapper-1-r1)
+#
+# Executes the correct fox-config version, based on the value of WANT_FOX.
+# All versions of fox after 1.0.x ship with a fox-config script
+#
+#
+# Stable branches first, in descending order, then unstable branches.
+# After a new stable branch, prepend the new version and bump (or remove)
+# the last unstable branch
+#
+vers="1.6 1.4 1.7"
+bindir=/usr/bin
+
+if [ "${0##*/}" = "fox-wrapper.sh" ] ; then
+ echo "fox-wrapper: Don't call this script directly, use fox-config instead" >&2
+ exit 1
+fi
+
+if [ -z "${WANT_FOX}" ] ; then
+ echo "fox-wrapper: Set the WANT_FOX variable to the desired version of fox, e.g.:" >&2
+ echo " WANT_FOX=\"1.6\" fox-config $@"
+ exit 1
+fi
+
+for v in ${vers} ; do
+ eval binary_${v/./_}="fox-${v}-config"
+done
+
+#
+# Check the WANT_FOX setting
+#
+for v in ${vers} x ; do
+ if [ "${v}" = "x" ] ; then
+ echo "fox-wrapper: WANT_FOX was set to an invalid version ${WANT_FOX}" >&2
+ echo " Valid values of WANT_FOX are: ${vers// /, }"
+ exit 1
+ fi
+
+ if [ "${WANT_FOX}" = "${v}" ] ; then
+ binary="binary_${v/./_}"
+ binary="${!binary}"
+ break
+ fi
+done
+
+if [ "${WANT_FOXWRAPPER_DEBUG}" ] ; then
+ echo "fox-wrapper: DEBUG: WANT_FOX is set to ${WANT_FOX}" >&2
+ echo "fox-wrapper: DEBUG: will execute <$binary>" >&2
+fi
+
+#
+# for further consistency
+#
+for v in ${vers} ; do
+ mybin="binary_${v/./_}"
+ if [ "${binary}" = "${!mybin}" ] ; then
+ export WANT_FOX="${v}"
+ fi
+done
+
+#
+# Now try to run the binary
+#
+if [ ! -x "${bindir}/${binary}" ] ; then
+ echo "fox-wrapper: $binary is missing or not executable." >&2
+ echo " Please try emerging the correct version of fox, i.e.:" >&2
+ echo " emerge '=x11-libs/${binary/-config/}*'" >&2
+ exit 1
+fi
+
+"$binary" "$@"
diff --git a/x11-libs/fox-wrapper/fox-wrapper-3.ebuild b/x11-libs/fox-wrapper/fox-wrapper-3.ebuild
new file mode 100644
index 000000000000..8f19c9bb1b28
--- /dev/null
+++ b/x11-libs/fox-wrapper/fox-wrapper-3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox-wrapper/fox-wrapper-3.ebuild,v 1.1 2009/03/01 22:58:16 mabi Exp $
+
+DESCRIPTION="wrapper for fox-config to manage multiple versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/lib/misc
+ newexe ${FILESDIR}/fox-wrapper-${PV}.sh fox-wrapper.sh || die
+
+ dodir /usr/bin
+ dosym ../lib/misc/fox-wrapper.sh /usr/bin/fox-config
+}