summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-10-08 16:37:54 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-10-08 16:37:54 +0000
commit93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb (patch)
tree9e25fd3c1279e093f618dcdd8f9a820e1f99e9f2 /x11-libs/gai
parentversion bump, #66773 (diff)
downloadgentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.tar.gz
gentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.tar.bz2
gentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.zip
version bump. fixes bug 59277
Diffstat (limited to 'x11-libs/gai')
-rw-r--r--x11-libs/gai/ChangeLog8
-rw-r--r--x11-libs/gai/Manifest6
-rw-r--r--x11-libs/gai/files/digest-gai-0.5.61
-rw-r--r--x11-libs/gai/gai-0.5.6.ebuild53
4 files changed, 65 insertions, 3 deletions
diff --git a/x11-libs/gai/ChangeLog b/x11-libs/gai/ChangeLog
index 9ea8e5299f88..85f9bb9ac653 100644
--- a/x11-libs/gai/ChangeLog
+++ b/x11-libs/gai/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gai
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.9 2004/08/08 00:50:25 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.10 2004/10/08 16:37:54 lordvan Exp $
+
+*gai-0.5.6 (08 Oct 2004)
+
+ 08 Oct 2004; root <root@gentoo.org> gai-0.5.6.ebuild:
+ version bump fixed Bug #59277 (Thanks to Daniel Webert
+ <rockoo@rockoo.homelinux.org>)
08 Aug 2004; Tom Martin <slarti@gentoo.org> gai-0.5.2.ebuild,
gai-0.5.3.ebuild, gai-0.5.5.ebuild:
diff --git a/x11-libs/gai/Manifest b/x11-libs/gai/Manifest
index b0016c500ce5..f0081b3ef40f 100644
--- a/x11-libs/gai/Manifest
+++ b/x11-libs/gai/Manifest
@@ -1,8 +1,10 @@
-MD5 effca07e1679b6491e85a981c564b690 ChangeLog 1548
MD5 5c8acb7365bbf46482c2ca5ac6711c96 gai-0.5.2.ebuild 1448
+MD5 7d0da014157fc8aad1f9e2ae224df604 gai-0.5.6.ebuild 1454
MD5 c8bac1b5fcb8245900077ea052f8fd45 gai-0.5.3.ebuild 1448
-MD5 7d0da014157fc8aad1f9e2ae224df604 gai-0.5.5.ebuild 1454
+MD5 effca07e1679b6491e85a981c564b690 ChangeLog 1548
MD5 4de810beafe6af976494dfe29abd5c60 metadata.xml 405
+MD5 7d0da014157fc8aad1f9e2ae224df604 gai-0.5.5.ebuild 1454
MD5 72db507aad739b6917552b17dac52b3c files/digest-gai-0.5.2 62
MD5 1f1765cd80db536972ec0fbfccb73136 files/digest-gai-0.5.3 62
MD5 b1b9fe26be39008ea87206a6cdf6414f files/digest-gai-0.5.5 62
+MD5 6c8e2086f432b1415f49005e79bdfe78 files/digest-gai-0.5.6 62
diff --git a/x11-libs/gai/files/digest-gai-0.5.6 b/x11-libs/gai/files/digest-gai-0.5.6
new file mode 100644
index 000000000000..164b3cba72f2
--- /dev/null
+++ b/x11-libs/gai/files/digest-gai-0.5.6
@@ -0,0 +1 @@
+MD5 7d14b0e6fe8f431d852b4cd70bc30fe9 gai-0.5.6.tar.bz2 238159
diff --git a/x11-libs/gai/gai-0.5.6.ebuild b/x11-libs/gai/gai-0.5.6.ebuild
new file mode 100644
index 000000000000..ffc2e0503843
--- /dev/null
+++ b/x11-libs/gai/gai-0.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.6.ebuild,v 1.1 2004/10/08 16:37:54 lordvan Exp $
+
+IUSE="opengl gnome"
+
+MY_P=${P/_/}
+DESCRIPTION="GAI, The General Applet Interface library is a library that will help applet programmers a lot."
+HOMEPAGE="http://gai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gai/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ppc"
+
+DEPEND=">=x11-libs/gtk+-2.0.0
+ opengl? ( >=x11-libs/gtkglext-1.0.5 )
+ gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # works with just set prefix (doesn't hardcode the prefix anywhere)!
+ local myconf
+
+ # Someone please tell upstream that the way to enable/disable things in
+ # configure scripts should be bloody well consistent -- it's in poor taste
+ # and downright incompetent to have to use --with if you want something
+ # and --disable if you don't
+
+ use opengl \
+ && myconf="${myconf} --with-gl" \
+ || myconf="${myconf} --disable-gl"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf \
+ --prefix=${D}/usr \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS COPYING.LIB ChangeLog INSTALL README \
+ README.gai THANKS TODO WINDOWMANAGERS
+ dohtml ${S}/docs/*
+ # install examples
+ cp -r ${S}/examples ${D}/usr/share/doc/${P}
+}