summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-06-16 10:44:50 +0000
committerPacho Ramos <pacho@gentoo.org>2012-06-16 10:44:50 +0000
commitac31054f4e5372c0d007dbf33b5b46ee995cb3c6 (patch)
treefff426dff13ccca727b615cafcfeedac07ba66b4 /x11-libs/gnome-pty-helper
parentVersion bump. (diff)
downloadgentoo-2-ac31054f4e5372c0d007dbf33b5b46ee995cb3c6.tar.gz
gentoo-2-ac31054f4e5372c0d007dbf33b5b46ee995cb3c6.tar.bz2
gentoo-2-ac31054f4e5372c0d007dbf33b5b46ee995cb3c6.zip
Version bump.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gnome-pty-helper')
-rw-r--r--x11-libs/gnome-pty-helper/ChangeLog7
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.32.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-libs/gnome-pty-helper/ChangeLog b/x11-libs/gnome-pty-helper/ChangeLog
index 228e506afb7b..30e670e9e0e2 100644
--- a/x11-libs/gnome-pty-helper/ChangeLog
+++ b/x11-libs/gnome-pty-helper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gnome-pty-helper
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gnome-pty-helper/ChangeLog,v 1.12 2012/04/14 09:11:58 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gnome-pty-helper/ChangeLog,v 1.13 2012/06/16 10:44:50 pacho Exp $
+
+*gnome-pty-helper-0.32.2 (16 Jun 2012)
+
+ 16 Jun 2012; Pacho Ramos <pacho@gentoo.org> +gnome-pty-helper-0.32.2.ebuild:
+ Version bump.
14 Apr 2012; Zac Medico <zmedico@gentoo.org> gnome-pty-helper-0.32.0.ebuild:
Add ~amd64-linux keyword.
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.32.2.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.32.2.ebuild
new file mode 100644
index 000000000000..28f19b9e55d4
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.32.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gnome-pty-helper/gnome-pty-helper-0.32.2.ebuild,v 1.1 2012/06/16 10:44:50 pacho Exp $
+
+EAPI="4"
+GNOME_ORG_MODULE="vte"
+
+inherit gnome.org
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+HOMEPAGE="http://git.gnome.org/browse/vte/"
+# gnome-pty-helper is inside vte
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+DEPEND=""
+
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+pkg_setup() {
+ # As recommended by upstream (/usr/libexec/$PN is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+}