summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:51:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:51:17 +0000
commitcdb427731f8497e2d3c7ae978e46dce88a0344e0 (patch)
tree79246d6f50d0e921b447b007defebfca4c1739b5 /x11-libs/gtksourceview
parentVersion bump. (diff)
downloadgentoo-2-cdb427731f8497e2d3c7ae978e46dce88a0344e0.tar.gz
gentoo-2-cdb427731f8497e2d3c7ae978e46dce88a0344e0.tar.bz2
gentoo-2-cdb427731f8497e2d3c7ae978e46dce88a0344e0.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog10
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.10.2.ebuild51
2 files changed, 59 insertions, 2 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 3e82d4787f3e..51acd7ba01ba 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.254 2013/12/24 15:27:21 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.255 2014/02/06 22:51:17 eva Exp $
+
+*gtksourceview-3.10.2 (06 Feb 2014)
+
+ 06 Feb 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtksourceview-3.10.2.ebuild:
+ Version bump.
*gtksourceview-3.10.1 (24 Dec 2013)
diff --git a/x11-libs/gtksourceview/gtksourceview-3.10.2.ebuild b/x11-libs/gtksourceview/gtksourceview-3.10.2.ebuild
new file mode 100644
index 000000000000..f9591c654003
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.10.2.ebuild,v 1.1 2014/02/06 22:51:17 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/2"
+IUSE="glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.9.9:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}