summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:19:20 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:19:20 +0000
commiteda3a8eb56234209b8925da37701cf9f6ba66993 (patch)
tree55a4a6d4adab045c4b57ed4bdbbf7222b9c60dc7 /x11-libs/gtksourceview
parentStable for ia64, wrt bug #461676 (diff)
downloadgentoo-2-eda3a8eb56234209b8925da37701cf9f6ba66993.tar.gz
gentoo-2-eda3a8eb56234209b8925da37701cf9f6ba66993.tar.bz2
gentoo-2-eda3a8eb56234209b8925da37701cf9f6ba66993.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog7
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.8.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 0f88bb933966..c5c6d5809674 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.244 2013/03/28 16:03:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.245 2013/03/28 22:19:20 pacho Exp $
+
+*gtksourceview-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gtksourceview-3.8.0.ebuild:
+ Version bump for Gnome 3.8
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> gtksourceview-3.6.3.ebuild:
Stable for arm, wrt bug #458984
diff --git a/x11-libs/gtksourceview/gtksourceview-3.8.0.ebuild b/x11-libs/gtksourceview/gtksourceview-3.8.0.ebuild
new file mode 100644
index 000000000000..f9b8f7fdd0e5
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.8.0.ebuild,v 1.1 2013/03/28 22:19:20 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/1"
+IUSE="glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND="
+ >=x11-libs/gtk+-3.7.12:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.34.0:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}