summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-25 17:57:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-25 17:57:09 +0000
commitf0910902df72d739c73cb0531ddf280e2a39dbfd (patch)
tree3ae6850bf663deb3d409dc79b81126809ff7d873 /x11-libs/libfm/libfm-0.1.17.ebuild
parentRemove old. (diff)
downloadgentoo-2-f0910902df72d739c73cb0531ddf280e2a39dbfd.tar.gz
gentoo-2-f0910902df72d739c73cb0531ddf280e2a39dbfd.tar.bz2
gentoo-2-f0910902df72d739c73cb0531ddf280e2a39dbfd.zip
version bump
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libfm/libfm-0.1.17.ebuild')
-rw-r--r--x11-libs/libfm/libfm-0.1.17.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libfm/libfm-0.1.17.ebuild b/x11-libs/libfm/libfm-0.1.17.ebuild
new file mode 100644
index 000000000000..e538d7a4fb3d
--- /dev/null
+++ b/x11-libs/libfm/libfm-0.1.17.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-0.1.17.ebuild,v 1.1 2011/10/25 17:57:09 hwoarang Exp $
+
+EAPI=4
+
+inherit autotools fdo-mime
+
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug examples udev"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ udev? ( dev-libs/dbus-glib )
+ >=lxde-base/menu-cache-0.3.2"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ udev? ( sys-fs/udisks )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -i -e '/^[[:space:]]*docs/d' -e "s:-O0::" \
+ configure.ac || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc" \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable udev udisks) \
+ $(use_enable examples demo) \
+ $(use_enable debug) \
+ # Documentation fails to build at the moment
+ # $(use_enable doc gtk-doc) \
+ # $(use_enable doc gtk-doc-html) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}