summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-05-21 18:54:13 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-05-21 18:54:13 +0000
commit92a41e6caa7adebc52962a9ed0262507bf3eb044 (patch)
tree92537b2587332218087d3222d6b610ad808f41bb /x11-libs/libnotify
parentBump to 0.7.3 (diff)
downloadgentoo-2-92a41e6caa7adebc52962a9ed0262507bf3eb044.tar.gz
gentoo-2-92a41e6caa7adebc52962a9ed0262507bf3eb044.tar.bz2
gentoo-2-92a41e6caa7adebc52962a9ed0262507bf3eb044.zip
Fix patch that failed to apply
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/ChangeLog6
-rw-r--r--x11-libs/libnotify/files/libnotify-0.7.3-gtk3-tests.patch97
-rw-r--r--x11-libs/libnotify/libnotify-0.7.3.ebuild4
3 files changed, 104 insertions, 3 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index d626d9109f77..73a7077af6b1 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libnotify
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.70 2011/05/21 18:45:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.71 2011/05/21 18:54:11 nirbheek Exp $
+
+ 21 May 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libnotify-0.7.3.ebuild,
+ +files/libnotify-0.7.3-gtk3-tests.patch:
+ Fix patch that failed to apply
*libnotify-0.7.3 (21 May 2011)
diff --git a/x11-libs/libnotify/files/libnotify-0.7.3-gtk3-tests.patch b/x11-libs/libnotify/files/libnotify-0.7.3-gtk3-tests.patch
new file mode 100644
index 000000000000..2f547357c7cc
--- /dev/null
+++ b/x11-libs/libnotify/files/libnotify-0.7.3-gtk3-tests.patch
@@ -0,0 +1,97 @@
+Don't build gtk+:3 tests if not required
+
+patch originally by Gilles (eva)
+
+---
+--- configure.ac
++++ configure.ac
+@@ -93,9 +93,13 @@
+ AC_SUBST([pkg_modules])
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+
++AC_ARG_ENABLE([tests],
++ AS_HELP_STRING([--enable-tests], [Check for extra dependencies to build all tests]))
++AS_IF([test $enable_tests = yes], [
+ tests_modules="gtk+-3.0 >= $REQ_GTK_VERSION"
+ PKG_CHECK_MODULES(TESTS, [$tests_modules])
+-
++])
++AM_CONDITIONAL([MORE_TESTS], [test $enable_tests = yes])
+ GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
+ AC_SUBST(GLIB_GENMARSHAL)
+
+--- tests/Makefile.am
++++ tests/Makefile.am
+@@ -2,18 +2,15 @@
+ -I$(top_srcdir) \
+ $(TESTS_CFLAGS)
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-replace \
+- test-replace-widget \
+ test-server-info \
+ test-default-action \
+ test-multi-actions \
+ test-action-icons \
+- test-image \
+ test-basic \
+ test-error \
+ test-markup \
+- test-persistence \
+ test-resident \
+ test-rtl \
+ test-size-changes \
+@@ -23,6 +20,22 @@
+ test-xy-actions \
+ test-xy-stress
+
++#if MORE_TESTS
++check_PROGRAMS += \
++ test-image \
++ test-replace-widget \
++ test-persistence
++
++test_replace_widget_SOURCES = test-replace-widget.c
++test_replace_widget_LDADD = $(common_ldflags)
++
++test_image_SOURCES = test-image.c
++test_image_LDADD = $(common_ldflags)
++
++test_persistence_SOURCES = test-persistence.c
++test_persistence_LDADD = $(common_ldflags)
++#endif
++
+ common_ldflags = \
+ $(top_builddir)/libnotify/libnotify.la \
+ $(TESTS_LIBS)
+@@ -30,9 +43,6 @@
+ test_replace_SOURCES = test-replace.c
+ test_replace_LDADD = $(common_ldflags)
+
+-test_replace_widget_SOURCES = test-replace-widget.c
+-test_replace_widget_LDADD = $(common_ldflags)
+-
+ test_server_info_SOURCES = test-server-info.c
+ test_server_info_LDADD = $(common_ldflags)
+
+@@ -48,9 +58,6 @@
+ test_action_icons_SOURCES = test-action-icons.c
+ test_action_icons_LDADD = $(common_ldflags)
+
+-test_image_SOURCES = test-image.c
+-test_image_LDADD = $(common_ldflags)
+-
+ test_basic_SOURCES = test-basic.c
+ test_basic_LDADD = $(common_ldflags)
+
+@@ -75,9 +82,6 @@
+ test_rtl_SOURCES = test-rtl.c
+ test_rtl_LDADD = $(common_ldflags)
+
+-test_persistence_SOURCES = test-persistence.c
+-test_persistence_LDADD = $(common_ldflags)
+-
+ test_resident_SOURCES = test-resident.c
+ test_resident_LDADD = $(common_ldflags)
+
diff --git a/x11-libs/libnotify/libnotify-0.7.3.ebuild b/x11-libs/libnotify/libnotify-0.7.3.ebuild
index 9f8a35684d22..ce1c50d9023c 100644
--- a/x11-libs/libnotify/libnotify-0.7.3.ebuild
+++ b/x11-libs/libnotify/libnotify-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.3.ebuild,v 1.1 2011/05/21 18:45:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.3.ebuild,v 1.2 2011/05/21 18:54:11 nirbheek Exp $
EAPI=3
inherit autotools eutils gnome.org
@@ -37,7 +37,7 @@ src_unpack() {
src_prepare() {
# Add configure switch for gtk+:3 based tests
# and make tests build only when needed
- epatch "${FILESDIR}"/${PN}-0.7.1-gtk3-tests.patch
+ epatch "${FILESDIR}"/${PN}-0.7.3-gtk3-tests.patch
AT_M4DIR=${WORKDIR} eautoreconf
}