summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-27 02:53:28 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-27 02:53:28 +0000
commita820d03af81e1024782555587d03e60899f84ddc (patch)
treed79854cd83c935984db14f4862f07b199328d811 /x11-libs/pango
parentunset GAMES_LIBDIR in games_get_libdir until everyone has converted off of GA... (diff)
downloadgentoo-2-a820d03af81e1024782555587d03e60899f84ddc.tar.gz
gentoo-2-a820d03af81e1024782555587d03e60899f84ddc.tar.bz2
gentoo-2-a820d03af81e1024782555587d03e60899f84ddc.zip
gnome 2.18.0
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.16.13
-rw-r--r--x11-libs/pango/pango-1.16.1.ebuild70
3 files changed, 79 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index cd92d19aff29..4d9f82808fd1 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.170 2007/03/22 21:33:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.171 2007/03/27 02:53:28 dang Exp $
+
+*pango-1.16.1 (27 Mar 2007)
+
+ 27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> +pango-1.16.1.ebuild:
+ gnome 2.18.0
22 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> pango-1.14.10.ebuild:
Stable on alpha/ia64/ppc wrt bug #163678.
diff --git a/x11-libs/pango/files/digest-pango-1.16.1 b/x11-libs/pango/files/digest-pango-1.16.1
new file mode 100644
index 000000000000..ff7b820ca869
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.16.1
@@ -0,0 +1,3 @@
+MD5 4aa720633e53701a652f27700a7946dd pango-1.16.1.tar.bz2 1354214
+RMD160 c97315a5685fc6fa3fc70638de6ef24e9d2739b9 pango-1.16.1.tar.bz2 1354214
+SHA256 8f4f4b4a9359cde35122124d7fa8725e0a8bc69bff0688202ce7d706489daa4b pango-1.16.1.tar.bz2 1354214
diff --git a/x11-libs/pango/pango-1.16.1.ebuild b/x11-libs/pango/pango-1.16.1.ebuild
new file mode 100644
index 000000000000..89cc67480771
--- /dev/null
+++ b/x11-libs/pango/pango-1.16.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.16.1.ebuild,v 1.1 2007/03/27 02:53:28 dang Exp $
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ >=dev-libs/glib-2.12
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.6"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ x11-proto/xproto
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" == "lib32" ] )
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch ${FILESDIR}/${PN}-1.2.5-lib64.patch
+ fi
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+ if [[ "${ROOT}" == "/" ]] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}