summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-12 23:47:32 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-12 23:47:32 +0000
commit2b4c37a221b636988c200524cd659e3134385bbc (patch)
tree5a8d80c2e1dd356686b9cc9f960581b3f64da135 /x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-2b4c37a221b636988c200524cd659e3134385bbc.tar.gz
gentoo-2-2b4c37a221b636988c200524cd659e3134385bbc.tar.bz2
gentoo-2-2b4c37a221b636988c200524cd659e3134385bbc.zip
Fix bug 370929.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild')
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild
index 4b2230c1ba02..b5eeba08cb95 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild
@@ -1,15 +1,20 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild,v 1.5 2012/02/10 00:51:18 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.4.ebuild,v 1.6 2012/04/12 23:47:32 pesa Exp $
EAPI="3"
inherit qt4-build
DESCRIPTION="The assistant help module for the Qt toolkit"
+SRC_URI+="
+ compat? (
+ ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz
+ http://dev.gentoo.org/~pesa/distfiles/${PN}-compat-headers-4.7.tar.gz
+ )"
+
SLOT="4"
KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86 ~ppc-macos"
IUSE="compat doc +glib qt3support trace"
-SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,glib=,qt3support=,trace?]
~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support=,sqlite]
@@ -19,7 +24,7 @@ RDEPEND="${DEPEND}"
pkg_setup() {
# Pixeltool isn't really assistant related, but it relies on
- # the assistant libraries. doc/qch/
+ # the assistant libraries.
QT4_TARGET_DIRECTORIES="
tools/assistant
tools/pixeltool
@@ -34,22 +39,24 @@ pkg_setup() {
use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
tools/qttracereplay"
+
QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
${QT4_EXTRACT_DIRECTORIES}"
+
qt4-build_pkg_setup
}
src_unpack() {
qt4-build_src_unpack
+
# compat version
# http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
if use compat; then
- unpack "${PN}"-qassistantclient-library-compat-src-4.6.3.tar.gz
- mv "${WORKDIR}"/"${PN}"-qassistantclient-library-compat-version-4.6.3 \
- "${S}"/tools/assistant/compat ||
- die "moving compat to the right place failed"
- tar xzf "${FILESDIR}"/"${PN}"-4.7-include.tar.gz -C "${S}"/include/ ||
- die "unpacking the include files failed"
+ unpack ${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz \
+ ${PN}-compat-headers-4.7.tar.gz
+ mv "${WORKDIR}"/${PN}-qassistantclient-library-compat-version-4.6.3 \
+ "${S}"/tools/assistant/compat || die
+ mv "${WORKDIR}"/QtAssistant "${S}"/include/ || die
fi
}