summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-29 17:07:26 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-29 17:07:26 +0000
commitced02a68b74082d9d3f507551dc6884270ef261c (patch)
tree8130451c78222787b46f1a105bbceb2a1423c3ff /x11-libs/qt-script
parentversion bump (diff)
downloadgentoo-2-ced02a68b74082d9d3f507551dc6884270ef261c.tar.gz
gentoo-2-ced02a68b74082d9d3f507551dc6884270ef261c.tar.bz2
gentoo-2-ced02a68b74082d9d3f507551dc6884270ef261c.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog10
-rw-r--r--x11-libs/qt-script/metadata.xml2
-rw-r--r--x11-libs/qt-script/qt-script-4.8.0.ebuild44
3 files changed, 54 insertions, 2 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 504f31f9c302..d8451403de4a 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.100 2011/12/27 21:23:42 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.101 2012/01/29 17:07:26 wired Exp $
+
+*qt-script-4.8.0 (29 Jan 2012)
+
+ 29 Jan 2012; Alex Alexander <wired@gentoo.org> +qt-script-4.8.0.ebuild,
+ metadata.xml:
+ version bump
27 Dec 2011; Markus Meier <maekke@gentoo.org> qt-script-4.7.4.ebuild:
x86 stable, bug #390963
diff --git a/x11-libs/qt-script/metadata.xml b/x11-libs/qt-script/metadata.xml
index 07df5376e0f4..0f820547fddf 100644
--- a/x11-libs/qt-script/metadata.xml
+++ b/x11-libs/qt-script/metadata.xml
@@ -8,5 +8,7 @@
<flag name="private-headers">Install Qt declarative private headers
required by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
<flag name="jit">Enables JIT for Javascript usage inside Qt</flag>
+ <flag name='c++0x'>Build Qt using the C++11 standard</flag>
+ <flag name='qpa'>Build a window system agnostic implementation of Qt</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-script/qt-script-4.8.0.ebuild b/x11-libs/qt-script/qt-script-4.8.0.ebuild
new file mode 100644
index 000000000000..d91d600f2fcf
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.8.0.ebuild,v 1.1 2012/01/29 17:07:26 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv +jit"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,c++0x=,qpa=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/script/"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtScript/
+ src/3rdparty/javascriptcore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) $(qt_use jit javascript-jit) -no-xkb
+ -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ #install private headers
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} \;
+}