summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-29 22:15:59 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-29 22:15:59 +0000
commit4e88a17c75508a5a8789a554dfd5967829f5c457 (patch)
treecd3e8f31e4421780a01aaeedc309a1d976a29bdb /x11-libs/qt-sql
parentVersion bump. (diff)
downloadgentoo-2-4e88a17c75508a5a8789a554dfd5967829f5c457.tar.gz
gentoo-2-4e88a17c75508a5a8789a554dfd5967829f5c457.tar.bz2
gentoo-2-4e88a17c75508a5a8789a554dfd5967829f5c457.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-sql')
-rw-r--r--x11-libs/qt-sql/ChangeLog7
-rw-r--r--x11-libs/qt-sql/qt-sql-4.8.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index ff9d1972413e..9b2d8ade2fa5 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.121 2012/03/27 18:34:00 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.122 2012/03/29 22:15:59 pesa Exp $
+
+*qt-sql-4.8.1 (29 Mar 2012)
+
+ 29 Mar 2012; Davide Pesavento <pesa@gentoo.org> +qt-sql-4.8.1.ebuild:
+ Version bump.
27 Mar 2012; Johannes Huber <johu@gentoo.org> -qt-sql-4.6.2.ebuild:
Drop Qt-4.6.2
diff --git a/x11-libs/qt-sql/qt-sql-4.8.1.ebuild b/x11-libs/qt-sql/qt-sql-4.8.1.ebuild
new file mode 100644
index 000000000000..e1359837a753
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.8.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.8.1.ebuild,v 1.1 2012/03/29 22:15:59 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird freetds mysql odbc postgres qt3support +sqlite"
+
+REQUIRED_USE="
+ || ( firebird freetds mysql odbc postgres sqlite )
+"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=,qt3support=]
+ firebird? ( dev-db/firebird )
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/sql
+ src/plugins/sqldrivers"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt
+ include/QtCore
+ include/QtSql
+ src/src.pro
+ src/corelib
+ src/plugins
+ src/tools/tools.pro"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ $(qt_use firebird sql-ibase plugin)
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql")
+ $(qt_use odbc sql-odbc plugin) $(use odbc && echo "-I${EPREFIX}/usr/include/iodbc")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo -system-sqlite)
+ -no-sql-db2
+ -no-sql-oci
+ -no-sql-sqlite2
+ -no-sql-symsql
+ $(qt_use qt3support)
+ -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon
+ -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg -no-openssl
+ -no-cups -no-dbus -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
+ -no-glib"
+
+ qt4-build_src_configure
+}