summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-12-05 13:18:04 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-12-05 13:18:04 +0000
commit0855268304ae195a4acd9dbe25e2e475ad2f6f35 (patch)
tree00ce072b1f53a826639ff69e055af9f4d06f6ca8 /x11-libs/qt
parentFixed jsch dependency to >=dev-java/jsch-0.1.24 to fix bug #157208. (diff)
downloadgentoo-2-0855268304ae195a4acd9dbe25e2e475ad2f6f35.tar.gz
gentoo-2-0855268304ae195a4acd9dbe25e2e475ad2f6f35.tar.bz2
gentoo-2-0855268304ae195a4acd9dbe25e2e475ad2f6f35.zip
A configure patch to ensure usage of system sqlite (bug #156123)
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/files/qt4-sqlite-configure.patch12
-rw-r--r--x11-libs/qt/qt-4.2.2.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index dafff49fdbde..836d5ba3c5b1 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.400 2006/12/05 13:13:29 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.401 2006/12/05 13:18:04 caleb Exp $
+
+ 05 Dec 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/qt4-sqlite-configure.patch, qt-4.2.2.ebuild:
+ A configure patch to ensure usage of system sqlite (bug #156123)
05 Dec 2006; Caleb Tennis <caleb@gentoo.org> qt-4.2.2.ebuild:
Can just use -confirm-license now instead of saying yes to the prompt
diff --git a/x11-libs/qt/files/qt4-sqlite-configure.patch b/x11-libs/qt/files/qt4-sqlite-configure.patch
new file mode 100644
index 000000000000..75b69b624486
--- /dev/null
+++ b/x11-libs/qt/files/qt4-sqlite-configure.patch
@@ -0,0 +1,12 @@
+--- configure.orig 2006-11-26 10:20:41.000000000 +0100
++++ configure 2006-11-26 10:22:49.000000000 +0100
+@@ -3595,8 +3595,8 @@
+ if "$unixtests/compile.test" "$XQMAKESPEC" $OPT_VERBOSE "$relpath" "$outpath" config.tests/unix/sqlite "SQLite" $QT_LFLAGS_SQLITE $L_FLAGS $QT_CFLAGS_SQLITE $I_FLAGS $l_FLAGS; then
+ if [ "$CFG_SQL_sqlite" = "auto" ]; then
+ CFG_SQL_sqlite=plugin
+- QMAKE_CONFIG="$QMAKE_CONFIG system-sqlite"
+ fi
++ QMAKE_CONFIG="$QMAKE_CONFIG system-sqlite"
+ else
+ SQLITE_AUTODETECT_FAILED="yes"
+ CFG_SQL_sqlite=no
diff --git a/x11-libs/qt/qt-4.2.2.ebuild b/x11-libs/qt/qt-4.2.2.ebuild
index 3b3213944db4..5f8f9534603f 100644
--- a/x11-libs/qt/qt-4.2.2.ebuild
+++ b/x11-libs/qt/qt-4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.2.ebuild,v 1.5 2006/12/05 13:13:29 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.2.ebuild,v 1.6 2006/12/05 13:18:04 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -108,6 +108,7 @@ src_unpack() {
cd ${S}
# epatch ${FILESDIR}/qt4-parisc-linux.diff
epatch ${FILESDIR}/qt-4.1.4-sparc.patch
+ epatch ${FILESDIR}/qt4-sqlite-configure.patch
cd mkspecs/$(qt_mkspecs_dir)
# set c/xxflags and ldflags