summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-12 19:32:24 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-12 19:32:24 +0000
commitb8ae2191655749a8ce653409447b22586ce7ffe3 (patch)
tree78bf345dae1f8750e7f929fdac9f142051e5df74 /x11-libs/tslib
parentBug #403261: no direct automake need, but OpenLDAP still needs a specific ver... (diff)
downloadgentoo-2-b8ae2191655749a8ce653409447b22586ce7ffe3.tar.gz
gentoo-2-b8ae2191655749a8ce653409447b22586ce7ffe3.tar.bz2
gentoo-2-b8ae2191655749a8ce653409447b22586ce7ffe3.zip
Sync patches with upstream, and drop custom `inputattach` addition #281456.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/tslib')
-rw-r--r--x11-libs/tslib/ChangeLog9
-rw-r--r--x11-libs/tslib/tslib-1.0-r2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/x11-libs/tslib/ChangeLog b/x11-libs/tslib/ChangeLog
index 4705785466c3..69ba0d64eb87 100644
--- a/x11-libs/tslib/ChangeLog
+++ b/x11-libs/tslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/tslib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/tslib/ChangeLog,v 1.15 2010/02/08 20:16:54 solar Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/tslib/ChangeLog,v 1.16 2012/02/12 19:32:24 vapier Exp $
+
+*tslib-1.0-r2 (12 Feb 2012)
+
+ 12 Feb 2012; Mike Frysinger <vapier@gentoo.org> +tslib-1.0-r2.ebuild:
+ Sync patches with upstream, and drop custom `inputattach` addition #281456.
08 Feb 2010; <solar@gentoo.org> tslib-1.0-r1.ebuild:
- tslib is not glib. it does not need to have versioned .pc files.
diff --git a/x11-libs/tslib/tslib-1.0-r2.ebuild b/x11-libs/tslib/tslib-1.0-r2.ebuild
new file mode 100644
index 000000000000..8930fe5af880
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/tslib/tslib-1.0-r2.ebuild,v 1.1 2012/02/12 19:32:23 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs autotools
+
+PATCH_VER="5"
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="http://tslib.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+#extras arctic2 collie corgi h3600 linear-h2200 mk712 ucb1x00"
+
+src_prepare() {
+ # patches come from buildroot + openembedded + suse
+ EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patch
+ eautoreconf
+}
+
+src_configure() {
+ # compile everything. INSTALL_MASK= what you don't want.
+ econf \
+ --enable-linear --enable-dejitter \
+ --enable-variance --enable-pthres \
+ --enable-input --enable-shared \
+ --enable-arctic2 --enable-collie \
+ --enable-corgi --enable-h3600 \
+ --enable-linear-h2200 --enable-mk712 \
+ --enable-ucb1x00 --disable-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}