summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-07 13:04:43 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-07 13:04:43 +0000
commit155822ab21204cd9ca3f90050e0fe86b077a0fa5 (patch)
treec8d45c81b705c5701a985c4cf031381dd65876f4 /x11-libs/wxGTK
parentversion bump and quite some changes in src_compile (diff)
downloadgentoo-2-155822ab21204cd9ca3f90050e0fe86b077a0fa5.tar.gz
gentoo-2-155822ab21204cd9ca3f90050e0fe86b077a0fa5.tar.bz2
gentoo-2-155822ab21204cd9ca3f90050e0fe86b077a0fa5.zip
disable unicode when using gtk2
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog5
-rw-r--r--x11-libs/wxGTK/Manifest4
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.0.ebuild19
3 files changed, 24 insertions, 4 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 41b9cfd740dc..8ac87a899692 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.28 2003/03/26 03:30:48 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.29 2003/05/07 13:04:34 liquidx Exp $
+
+ 07 May 2003; Alastair Tse <liquidx@gentoo.org> wxGTK-2.4.0.ebuild:
+ disable unicode support for gtk2
*wxGTK-2.4.0 (01 Jan 2003)
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
new file mode 100644
index 000000000000..62a02f2d6457
--- /dev/null
+++ b/x11-libs/wxGTK/Manifest
@@ -0,0 +1,4 @@
+MD5 af4e8ec4249b982a11c0e2986d06cac7 ChangeLog 5231
+MD5 7b6cbaf39f7346190040182c8c0bf5c8 wxGTK-2.4.0.ebuild 2705
+MD5 16ea0622454512339b2c613af61a9aa4 files/digest-wxGTK-2.4.0 65
+MD5 12af4ba0b1a2a2174fc047c2908090ce files/wxGTK-2.2.9.diff.gz 272
diff --git a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
index 1466a79057a6..84b1f1b482dd 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.9 2003/03/26 03:30:48 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.10 2003/05/07 13:04:34 liquidx Exp $
DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
@@ -50,6 +50,10 @@ src_compile() {
&& myconf="${myconf} --enable-static" \
|| myconf="${myconf} --disable-static"
+ # Note: ODBC support does not work with --enable-unicode
+ # We only use --enable-unicode (if at all) when we use
+ # gtk2.
+
if [ `use odbc` ] && [ ! `use gtk2` ]; then
myconf="${myconf} --with-odbc"
elif [ `use odbc` ] && [ `use gtk2` ]; then
@@ -69,8 +73,17 @@ src_compile() {
|| myconf="${myconf} --without-opengl"
myconf="${myconf} --with-x --with-gtk"
-
- use gtk2 && myconf="${myconf} --enable-gtk2 --enable-unicode"
+
+ # here we disable unicode support even thought gtk2 supports it
+ # because too many apps just don't follow the wxWindows guidelines
+ # for unicode support.
+ #
+ # http://www.wxwindows.org/manuals/2.4.0/wx458.htm#unicode
+ #
+ # ref #20116 - liquidx@gentoo.org (07 May 2003)
+
+ #use gtk2 && myconf="${myconf} --enable-gtk2 --enable-unicode"
+ use gtk2 && myconf="${myconf} --enable-gtk2"
econf ${myconf}
emake || die "make failed"