summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-08-10 06:07:51 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-08-10 06:07:51 +0000
commit4d5936f551dd15a6eee29813b3e26ea1ecd6c9ed (patch)
tree5cb7b80291ebb442fdf826cd2570dec9d9447975 /x11-libs/wxGTK
parentVersion bump. (diff)
downloadgentoo-2-4d5936f551dd15a6eee29813b3e26ea1ecd6c9ed.tar.gz
gentoo-2-4d5936f551dd15a6eee29813b3e26ea1ecd6c9ed.tar.bz2
gentoo-2-4d5936f551dd15a6eee29813b3e26ea1ecd6c9ed.zip
Port to EAPI 5. Fix x32 build again (bug #421851). Add epatch_user. Restore
missing removal of wxmsw.mo to 2.9 ebuilds to prevent file collisions. Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog11
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild187
-rw-r--r--x11-libs/wxGTK/wxGTK-2.9.3.1-r1.ebuild177
-rw-r--r--x11-libs/wxGTK/wxGTK-2.9.4.1-r1.ebuild179
4 files changed, 553 insertions, 1 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index c9edc4b03c95..ef7fe63dd7e1 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.299 2013/03/26 03:47:46 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.300 2013/08/10 06:07:51 dirtyepic Exp $
+
+*wxGTK-2.9.4.1-r1 (10 Aug 2013)
+*wxGTK-2.9.3.1-r1 (10 Aug 2013)
+*wxGTK-2.8.12.1-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Ryan Hill <dirtyepic@gentoo.org> +wxGTK-2.8.12.1-r1.ebuild,
+ +wxGTK-2.9.3.1-r1.ebuild, +wxGTK-2.9.4.1-r1.ebuild:
+ Port to EAPI 5. Fix x32 build again (bug #421851). Add epatch_user. Restore
+ missing removal of wxmsw.mo to 2.9 ebuilds to prevent file collisions.
26 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.9.3.1.ebuild,
wxGTK-2.9.4.1.ebuild:
diff --git a/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild
new file mode 100644
index 000000000000..2cca3e566a28
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild,v 1.1 2013/08/10 06:07:51 dirtyepic Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="http://wxwidgets.org/"
+
+BASE_PV="$(get_version_component_range 1-3)"
+BASE_P="${PN}-${BASE_PV}"
+
+# we use the wxPython tarballs because they include the full wxGTK sources and
+# docs, and are released more frequently than wxGTK.
+SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gnome gstreamer odbc opengl pch sdl tiff"
+
+SLOT="2.8"
+
+RDEPEND="
+ dev-libs/expat
+ odbc? ( dev-db/unixODBC )
+ sdl? ( media-libs/libsdl )
+ X? (
+ dev-libs/glib:2
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/libSM
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ x11-libs/pango[X]
+ gnome? ( gnome-base/libgnomeprintui:2.2 )
+ gstreamer? (
+ gnome-base/gconf:2
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ opengl? ( virtual/opengl )
+ tiff? ( media-libs/tiff:0 )
+ )
+ aqua? (
+ >=x11-libs/gtk+-2.4[aqua=]
+ virtual/jpeg
+ tiff? ( media-libs/tiff:0 )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ opengl? ( virtual/glu )
+ X? (
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ x11-proto/xf86vidmodeproto
+ )"
+
+PDEPEND=">=app-admin/eselect-wxwidgets-0.7"
+
+LICENSE="wxWinLL-3
+ GPL-2
+ odbc? ( LGPL-2 )
+ doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxPython-src-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.11-unicode-odbc.patch
+ epatch "${FILESDIR}"/${PN}-2.8.11-collision.patch
+ epatch "${FILESDIR}"/${PN}-2.8.7-mmedia.patch # Bug #174874
+ epatch "${FILESDIR}"/${PN}-2.8.10.1-odbc-defines.patch # Bug #310923
+
+ # x32 https://bugs.gentoo.org/421851
+ sed -i -e "/wx_cv_std_libpath=/s:=.*:=$(get_libdir):" configure || die
+
+ # prefix https://bugs.gentoo.org/394123
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" \
+ -e '/SEARCH_INCLUDE="\\/,/"/cSEARCH_INCLUDE="'${EPREFIX}'/usr/include"' \
+ configure || die
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+
+ append-flags -fno-strict-aliasing
+
+ # X independent options
+ myconf="--enable-compat26
+ --enable-shared
+ --enable-unicode
+ --with-regex=builtin
+ --with-zlib=sys
+ --with-expat=sys
+ $(use_enable debug)
+ $(use_enable pch precomp-headers)
+ $(use_with odbc odbc sys)
+ $(use_with sdl)
+ $(use_with tiff libtiff sys)"
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ $(use_enable gstreamer mediactrl)
+ $(use_enable opengl)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ --without-gnomevfs"
+
+ use aqua && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-mac
+ --with-opengl"
+ # cocoa toolkit seems to be broken
+
+ # wxBase options
+ if use !X && use !aqua ; then
+ myconf="${myconf}
+ --disable-gui"
+ fi
+
+ mkdir "${S}"/wxgtk_build
+ cd "${S}"/wxgtk_build
+
+ ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+src_compile() {
+ cd "${S}"/wxgtk_build
+
+ emake
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}"/wxgtk_build
+
+ emake DESTDIR="${D}" install
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake DESTDIR="${D}" install
+ fi
+
+ cd "${S}"/docs
+ dodoc changes.txt readme.txt todo30.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ if use doc; then
+ dohtml -r "${S}"/docs/html/*
+ fi
+
+ # Stray windows locale file, causes collisions
+ local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+ [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+}
+
+pkg_postinst() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
diff --git a/x11-libs/wxGTK/wxGTK-2.9.3.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.9.3.1-r1.ebuild
new file mode 100644
index 000000000000..235255b7904f
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.9.3.1-r1.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.9.3.1-r1.ebuild,v 1.1 2013/08/10 06:07:51 dirtyepic Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="http://wxwidgets.org/"
+
+# we use the wxPython tarballs because they include the full wxGTK sources and
+# docs, and are released more frequently than wxGTK.
+SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2
+ doc? ( mirror://sourceforge/wxpython/wxPython-docs-${PV}.tar.bz2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gnome gstreamer opengl pch sdl tiff webkit"
+
+SLOT="2.9/2.9.3"
+
+RDEPEND="
+ dev-libs/expat
+ sdl? ( media-libs/libsdl )
+ X? (
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libSM
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ x11-libs/pango[X]
+ gnome? ( gnome-base/libgnomeprintui:2.2 )
+ gstreamer? (
+ gnome-base/gconf:2
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ opengl? ( virtual/opengl )
+ tiff? ( media-libs/tiff:0 )
+ webkit? ( net-libs/webkit-gtk:2 )
+ )
+ aqua? (
+ >=x11-libs/gtk+-2.4[aqua=]
+ virtual/jpeg
+ tiff? ( media-libs/tiff:0 )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ opengl? ( virtual/glu )
+ X? (
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ x11-proto/xf86vidmodeproto
+ )"
+# test? ( dev-util/cppunit )
+
+PDEPEND=">=app-admin/eselect-wxwidgets-1.4"
+
+LICENSE="wxWinLL-3
+ GPL-2
+ doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxPython-src-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-collision.patch
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+
+ append-flags -fno-strict-aliasing
+
+ # X independent options
+ myconf="--enable-compat26
+ --with-zlib=sys
+ --with-expat=sys
+ $(use_enable pch precomp-headers)
+ $(use_with sdl)"
+
+ # debug in >=2.9
+ # if USE="debug" set max debug level (wxDEBUG_LEVEL=2)
+ # if USE="-debug" use the default (wxDEBUG_LEVEL=1)
+ # do not use --disable-debug
+ # this means we always build debugging features into the library, and
+ # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+ # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+ # http://docs.wxwidgets.org/2.9/overview_debugging.html
+ # http://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+ use debug \
+ && myconf="${myconf} --enable-debug=max"
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --without-gnomevfs
+ $(use_enable gstreamer mediactrl)
+ $(use_enable webkit webview)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ $(use_with !gnome gtkprint)
+ $(use_with tiff libtiff sys)"
+
+ use aqua && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-mac
+ --with-opengl"
+ # cocoa toolkit seems to be broken
+
+ # wxBase options
+ if use !X && use !aqua ; then
+ myconf="${myconf}
+ --disable-gui"
+ fi
+
+ mkdir "${S}"/wxgtk_build
+ cd "${S}"/wxgtk_build
+
+ ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+src_compile() {
+ cd "${S}"/wxgtk_build
+ emake
+}
+
+# Currently fails - need to investigate
+#src_test() {
+# cd "${S}"/wxgtk_build/tests
+# emake || die "failed building testsuite"
+# ./test -d || ewarn "failed running testsuite"
+#}
+
+src_install() {
+ cd "${S}"/wxgtk_build
+
+ emake DESTDIR="${D}" install
+
+ cd "${S}"/docs
+ dodoc changes.txt readme.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ if use doc; then
+ dohtml -r "${S}"/docs/doxygen/out/html/*
+ fi
+
+ # Stray windows locale file, causes collisions
+ local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+ [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+}
+
+pkg_postinst() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
diff --git a/x11-libs/wxGTK/wxGTK-2.9.4.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.9.4.1-r1.ebuild
new file mode 100644
index 000000000000..f552fcc834c9
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.9.4.1-r1.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.9.4.1-r1.ebuild,v 1.1 2013/08/10 06:07:51 dirtyepic Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="http://wxwidgets.org/"
+
+# we use the wxPython tarballs because they include the full wxGTK sources and
+# docs, and are released more frequently than wxGTK.
+SRC_URI="mirror://sourceforge/wxpython/wxPython-src-2.9.4.0.tar.bz2
+ doc? ( mirror://sourceforge/wxpython/wxPython-docs-2.9.4.0.tar.bz2 )
+ mirror://sourceforge/wxpython/wxPython-src-${PV}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gnome gstreamer opengl pch sdl tiff webkit"
+
+SLOT="2.9/2.9.4"
+
+RDEPEND="
+ dev-libs/expat
+ sdl? ( media-libs/libsdl )
+ X? (
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libSM
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ x11-libs/pango[X]
+ gnome? ( gnome-base/libgnomeprintui:2.2 )
+ gstreamer? (
+ gnome-base/gconf:2
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ opengl? ( virtual/opengl )
+ tiff? ( media-libs/tiff:0 )
+ webkit? ( net-libs/webkit-gtk:2 )
+ )
+ aqua? (
+ >=x11-libs/gtk+-2.4[aqua=]
+ virtual/jpeg
+ tiff? ( media-libs/tiff:0 )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ opengl? ( virtual/glu )
+ X? (
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ x11-proto/xf86vidmodeproto
+ )"
+# test? ( dev-util/cppunit )
+
+PDEPEND=">=app-admin/eselect-wxwidgets-1.4"
+
+LICENSE="wxWinLL-3
+ GPL-2
+ doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxPython-src-2.9.4.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-collision.patch
+ epatch "${DISTDIR}"/wxPython-src-${PV}.patch
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+
+ append-flags -fno-strict-aliasing
+
+ # X independent options
+ myconf="--enable-compat26
+ --with-zlib=sys
+ --with-expat=sys
+ $(use_enable pch precomp-headers)
+ $(use_with sdl)"
+
+ # debug in >=2.9
+ # if USE="debug" set max debug level (wxDEBUG_LEVEL=2)
+ # if USE="-debug" use the default (wxDEBUG_LEVEL=1)
+ # do not use --disable-debug
+ # this means we always build debugging features into the library, and
+ # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+ # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+ # http://docs.wxwidgets.org/2.9/overview_debugging.html
+ # http://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+ use debug \
+ && myconf="${myconf} --enable-debug=max"
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --without-gnomevfs
+ $(use_enable gstreamer mediactrl)
+ $(use_enable webkit webview)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ $(use_with !gnome gtkprint)
+ $(use_with tiff libtiff sys)"
+
+ use aqua && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-mac
+ --with-opengl"
+ # cocoa toolkit seems to be broken
+
+ # wxBase options
+ if use !X && use !aqua ; then
+ myconf="${myconf}
+ --disable-gui"
+ fi
+
+ mkdir "${S}"/wxgtk_build
+ cd "${S}"/wxgtk_build
+
+ ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+src_compile() {
+ cd "${S}"/wxgtk_build
+ emake
+}
+
+# Currently fails - need to investigate
+#src_test() {
+# cd "${S}"/wxgtk_build/tests
+# emake || die "failed building testsuite"
+# ./test -d || ewarn "failed running testsuite"
+#}
+
+src_install() {
+ cd "${S}"/wxgtk_build
+
+ emake DESTDIR="${D}" install
+
+ cd "${S}"/docs
+ dodoc changes.txt readme.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ if use doc; then
+ dohtml -r "${S}"/docs/doxygen/out/html/*
+ fi
+
+ # Stray windows locale file, causes collisions
+ local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+ [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+}
+
+pkg_postinst() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}