summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-04 04:23:44 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-04 04:23:44 +0000
commitff27f738e396ee282244707183fd78c1960452f6 (patch)
tree863040a3851fa0e5ff657dc792d5758442d9a457 /x11-libs/wxmozilla
parentstop trying to use the obsolete -r option to nasm (diff)
downloadgentoo-2-ff27f738e396ee282244707183fd78c1960452f6.tar.gz
gentoo-2-ff27f738e396ee282244707183fd78c1960452f6.tar.bz2
gentoo-2-ff27f738e396ee282244707183fd78c1960452f6.zip
Fix configure to find wxpython-2.6 install instead of highest version
available. (Portage version: 2.1.4_rc7)
Diffstat (limited to 'x11-libs/wxmozilla')
-rw-r--r--x11-libs/wxmozilla/ChangeLog8
-rw-r--r--x11-libs/wxmozilla/files/wxmozilla-0.5.7-wxversion.patch21
-rw-r--r--x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild7
3 files changed, 33 insertions, 3 deletions
diff --git a/x11-libs/wxmozilla/ChangeLog b/x11-libs/wxmozilla/ChangeLog
index 1a31e37ab157..dc26a557d116 100644
--- a/x11-libs/wxmozilla/ChangeLog
+++ b/x11-libs/wxmozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxmozilla
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.14 2007/09/16 05:07:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.15 2007/12/04 04:23:43 dirtyepic Exp $
+
+ 04 Dec 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxmozilla-0.5.7-wxversion.patch,
+ wxmozilla-0.5.7_pre20070102.ebuild:
+ Fix configure to find wxpython-2.6 install instead of highest version
+ available.
16 Sep 2007; Ryan Hill <dirtyepic@gentoo.org>
+files/wxmozilla-0.5.7-python-2.5.patch,
diff --git a/x11-libs/wxmozilla/files/wxmozilla-0.5.7-wxversion.patch b/x11-libs/wxmozilla/files/wxmozilla-0.5.7-wxversion.patch
new file mode 100644
index 000000000000..e89c490be862
--- /dev/null
+++ b/x11-libs/wxmozilla/files/wxmozilla-0.5.7-wxversion.patch
@@ -0,0 +1,21 @@
+diff -Naur wxMozilla-orig/configure.in wxMozilla/configure.in
+--- wxMozilla-orig/configure.in 2006-11-15 08:19:06.000000000 -0600
++++ wxMozilla/configure.in 2007-12-03 22:03:09.000000000 -0600
+@@ -287,7 +287,7 @@
+ if test "$wxrelease" = 2.4 ; then
+ WXPYTHONDIR="$pythondir"
+ else
+- wxpyvername=`$PYTHON -c "from wx.build.config import getExtraPath; print getExtraPath(addOpts=1)"`
++ wxpyvername=`$PYTHON -c "import wxversion; wxversion.select('2.6'); from wx.build.config import getExtraPath; print getExtraPath(addOpts=1)"`
+ WXPYTHONDIR="$pythondir/$wxpyvername"
+ fi
+
+@@ -295,7 +295,7 @@
+ AC_MSG_RESULT([$WXPYTHONDIR])
+
+ AC_MSG_CHECKING([whether wxPython is >= 2.6.3])
+- wxpyverok=`$PYTHON -c "import wx; print wx.__version__ > '2.6.3'"`
++ wxpyverok=`$PYTHON -c "import wxversion; wxversion.select('2.6'); import wx; print wx.__version__ > '2.6.3'"`
+ if test "$wxpyverok" = "True" ; then
+ AC_MSG_RESULT([yes])
+ else
diff --git a/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild b/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
index c2e1d000a173..ce7ddd3e59dc 100644
--- a/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
+++ b/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild,v 1.4 2007/09/16 05:07:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild,v 1.5 2007/12/04 04:23:43 dirtyepic Exp $
-inherit eutils wxwidgets
+inherit eutils wxwidgets autotools
# Currently force building against firefox. Seamonkey is supported but
# crashes. Upstream will fix and release as 0.5.7. bug #130969
@@ -35,6 +35,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.5.7-python-2.5.patch
+ epatch "${FILESDIR}"/${PN}-0.5.7-wxversion.patch
+
+ eautoconf
}
src_compile() {